PTA甲级 1094 The Largest Generation (C++)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N ( < 100 ) N (<100) N(<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N N N), and M ( < N ) M (<N) M(<N) which is the number of family members who have children. Then M M M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K ( > 0 >0 >0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-02 15:28:02
// All rights reserved.

#include <iostream>
#include <vector>
#include <queue>

using namespace std;

int main(){
    int n, m;
    // n - the total number of family members in the tree 
    // (and hence assume that all the members are numbered from 01 to N)
    // m -  the number of family members who have children

    scanf("%d %d", &n, &m);
    vector<vector<int>> children(n + 1);

    for(int i = 0; i < m; ++i){
        int id, num;
        scanf("%d %d", &id, &num);

        for(int j = 0; j < num; ++j){
            int tmp;
            scanf("%d", &tmp);
            children[id].push_back(tmp);
        }
    }

    int level = 1;
    int ans = -1;
    int ansLevel = 0;

    queue<int> q;
    q.push(1);
    while(!q.empty()){
        int size = q.size();

        if(size > ans){
            ans = size;
            ansLevel = level;
        }

        for(int i = 0; i < size; ++i){
            int tmp = q.front();
            q.pop();

            for(int j = 0; j < children[tmp].size(); ++j) q.push(children[tmp][j]);
        }

        level++;
    }

    printf("%d %d\n", ans, ansLevel);

    return 0;
}

在这里插入图片描述

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值