PTA甲级 1056 Mice and Rice (C++)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N P N_P NP programmers. Then every N G N_G NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N G N_G NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N P N_P NP and N G ( ≤ 1000 ) N_G(≤1000) NG(1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N G N_G NG mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N P N_P NP distinct non-negative numbers W i ( i = 0 , ⋯ , N P − 1 ) W_i(i=0,⋯,N_P−1) Wi(i=0,,NP1) where each W i W_i Wi is the weight of the i i i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0 , ⋯ , N P − 1 0,⋯,N_P−1 0,,NP1 (assume that the programmers are numbered from 0 to N P − 1 N_P−1 NP1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i i i-th number is the rank of the i i i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

Caution:

因为有两个第 3 名所以示例中第 3 名之后直接是第 5 名,刚开始这一点一直没搞明白。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-04 11:55:38
// All rights reserved.

#include <iostream>
#include <vector>
#include <stack>

using namespace std;

int main(){
    int np, ng;
    scanf("%d %d", &np, &ng);
    
    vector<int> weights(np);
    vector<int> sequence(np);
    vector<int> sequence2;
    bool flag = true;
    // flag = true 表示 sequence 有效,下一步覆盖 sequence2
    // flag = false 表示 sequence2 有效,下一步覆盖 sequence
    vector<int> rank(np);

    for(int i = 0; i < np; ++i) scanf("%d", &weights[i]);
    for(int i = 0; i < np; ++i) scanf("%d", &sequence[i]);

    stack<int> s;

    while(true){
        if(sequence.empty() && sequence2.size() == 1){
            s.push(sequence2[0]);
            break;
        }
        else if(sequence2.empty() && sequence.size() == 1){
            s.push(sequence[0]);
            break;
        }

        if(flag){
            // flag = true 表示 sequence 有效,下一步覆盖 sequence2            
            for(int i = 0; i < sequence.size(); i += ng){
                int l = i;
                int r = min(i + ng - 1, (int)sequence.size() - 1);

                int maxPos = -1;
                int maxRice = -1;

                for(int j = l; j <= r; ++j){
                    if(weights[sequence[j]] > maxRice){
                        maxPos = sequence[j];
                        maxRice = weights[sequence[j]];
                    }
                }

                for(int j = l; j <= r; ++j){
                    if(maxPos == sequence[j]) sequence2.push_back(maxPos);
                    else s.push(sequence[j]);
                }
            }

            sequence.clear();
            s.push(-1);
        }
        else{
            // flag = false 表示 sequence2 有效,下一步覆盖 sequence
            for(int i = 0; i < sequence2.size(); i += ng){
                int l = i;
                int r = min(i + ng - 1, (int)sequence2.size() - 1);

                int maxPos = -1;
                int maxRice = -1;

                for(int j = l; j <= r; ++j){
                    if(weights[sequence2[j]] > maxRice){
                        maxPos = sequence2[j];
                        maxRice = weights[sequence2[j]];
                    }
                }

                for(int j = l; j <= r; ++j){
                    if(maxPos == sequence2[j]) sequence.push_back(maxPos);
                    else s.push(sequence2[j]);
                }
            }

            sequence2.clear();
            s.push(-1);
        }

        flag = !flag;
    }
    
    int tmpRank = 1;
    int cnt = 0;
    while(!s.empty()){
        if(s.top() == -1){
            tmpRank = cnt + 1;
            s.pop();
            continue;
        }
        
        rank[s.top()] = tmpRank;
        s.pop();
        cnt++;
    }

    for(int i = 0; i < np; ++i){
        if(i == np - 1) printf("%d\n", rank[i]);
        else printf("%d ", rank[i]);
    }

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值