PTA甲级 1018 Public Bike Management (C++)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.
在这里插入图片描述
The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S S S is the current number of bikes stored at S S S. Given that the maximum capacity of each station is 10. To solve the problem at S 3 S_3 S3, we have 2 different shortest paths:

  1. PBMC -> S 1 S_1 S1 -> S 3 S_3 S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S 1 S_1 S1 and then take 5 bikes to S 3 S_3 S3, so that both stations will be in perfect conditions.
  2. PBMC -> S 2 S_2 S2 -> S 3 S_3 S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C m a x ( ≤ 100 ) C_{max}(≤100) Cmax(100), always an even number, is the maximum capacity of each station; N ( ≤ 500 ) N (≤500) N(500), the total number of stations; S p S_p Sp, the index of the problem station (the stations are numbered from 1 to N N N, and PBMC is represented by the vertex 0); and M M M, the number of roads. The second line contains N N N non-negative numbers C i ( i = 1 , ⋯ , N ) C_i(i=1,⋯,N) Ci(i=1,,N) where each C i C_i Ci is the current number of bikes at S i S_i Si respectively. Then M M M lines follow, each contains 3 numbers: S i S_i Si, S j S_j Sj, and T i j T_{ij} Tij which describe the time T i j T_{ij} Tij taken to move betwen stations S i S_i Si and S j S_j Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0 − > S 1 − > ⋯ − > S p 0−>S_1−>⋯−>S_p 0>S1>>Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S p S_p Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

Caution:

建议看一下《算法笔记》10.4.1的内容,Dijkstra + DFS。

Solution:

// Talk is cheap, show me the code
// Created by Pengxiao Guo 2021-09-03 18:45:28
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int cmax, n, sp, m;
int storage[505];
int streets[505][505];
int dis[505];
vector<vector<int>> pre;

int minNeed = 2147483647, minBack = 2147483647;
unordered_map<int, bool> visited;

vector<int> ans;
vector<int> tmp;

void dfs(int idx){
    tmp.push_back(idx);

    if(idx == 0){
        int need = 0, back = 0;

        for(int i = tmp.size() - 2; i >= 0; --i){
            int id = tmp[i];

            if(storage[id] >= cmax / 2) back += storage[id] - cmax / 2;
            else{
                if(back > (cmax / 2 - storage[id])) back += storage[id] - cmax / 2;
                else{
                    need += (cmax / 2 - storage[id] - back);
                    back = 0;
                }
            }
        }

        if(need < minNeed){
            minNeed = need;
            minBack = back;
            ans = tmp;
        }
        else if(need == minNeed && back < minBack){
            minBack = back;
            ans = tmp;
        }

        tmp.pop_back();
        return;
    }

    for(int i = 0; i < pre[idx].size(); ++i) dfs(pre[idx][i]);
    tmp.pop_back();

    return;
}


int main(){

    fill(dis, dis + 505, 2147483647);
    scanf("%d %d %d %d", &cmax, &n, &sp, &m);
    pre.resize(n + 1);

    for(int i = 1; i <= n; ++i) scanf("%d", &storage[i]);

    for(int i = 0; i < m; ++i){
        int s1, s2, t;
        scanf("%d %d %d", &s1, &s2, &t);

        streets[s1][s2] = t;
        streets[s2][s1] = t;
    }

    // Dijkstra
    dis[0] = 0;
    for(int i = 0; i < n; ++i){

        int u = -1, minDis = 2147483647;

        for(int j = 0; j <= n; ++j){
            if(!visited[j] && dis[j] < minDis){
                u = j;
                minDis = dis[j];
            }
        }

        if(u == -1) break;
        visited[u] = true;

        for(int j = 0; j <= n; ++j){
            if(!visited[j] && streets[u][j] != 0){
                if(dis[j] > dis[u] + streets[u][j]){
                    dis[j] = dis[u] + streets[u][j];
                    pre[j].clear();
                    pre[j].push_back(u);
                }
                else if(dis[j] == dis[u] + streets[u][j]) pre[j].push_back(u);
            }
        }
    }

    dfs(sp);

    printf("%d 0", minNeed);
    for(int i = ans.size() - 2; i >= 0; --i) printf("->%d", ans[i]);
    printf(" %d\n", minBack);

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值