PTA甲级 1018 Public Bike Management (30分)

本文介绍了一种利用Dijkstra算法和深度优先搜索解决PTA(Public Bike Management Center)自行车管理系统中调整车站自行车平衡问题的方法。当某车站需要调整到理想状态时,寻找最短路径并考虑最少的自行车补给与回收。文章提供了详细的代码实现和样例输入输出。
摘要由CSDN通过智能技术生成

强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

还有就是非常非常有用的 算法笔记 全名是

算法笔记  上级训练实战指南		//这本都是PTA的题解
算法笔记

PS 今天也要加油鸭

在这里插入图片描述

题目原文

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

img

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

  1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.
  2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cma**x (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S**p, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C**i (i=1,⋯,N) where each C**i is the current number of bikes at S**i respectively. Then M lines follow, each contains 3 numbers: S**i, S**j, and Tij which describe the time Tij taken to move betwen stations S**i and S**j. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S1−>⋯−>S**p. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S**p is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

生词如下:

看懂了.

这种题目就是要静下心来做.慢慢读题

题目大意:

就是杭州的自行车管理系统.

翻译成图相关的就是

有一个图.

起始顶点是0 我们的终点是sp.然后在寻找最短路径.

如果有多个最短路径,那就选择需要补给的车最少的.

如果需要补给的车数量是一样的.就选择带会来的车数量最少的.

思路如下:

用Dijkstra+DFS的模板做

代码如下:

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
const int MAXV = 510;	//最大顶点数
const int INF = 1000000000;	//无穷大
//n为顶点数,m为边数,Cmax为最大容量.Sp为问题站点
//G为邻接矩阵,weight为点权,minReamin记录最少带回的数目
int n, m, Cmax, Sp, numPath = 0, G[MAXV][MAXV], weight[MAXV],d[MAXV];
int vis[MAXV] = { false };									//vis[i]==true
vector<int> pre[MAXV];		//前驱
vector<int> tempPath, path;	//临时路径及最优路径
int minNeed = INF, minRemain = INF;
void Dijkstra(int s) {
	fill(d, d + MAXV, INF);
	d[s] = 0;
	for (int i = 0; i <= n; ++i) {
		int u = -1, MIN = INF;
		for (int j = 0; j <= n; ++j) {
			if (vis[j] == false && d[j] < MIN) {
				u = j;
				MIN = d[j];
			}
		}
		//找不到小于INF的d[u],说明剩下的顶点和起点s不连通.
		if (u == -1)	return;
		vis[u] = true;	//标记u为已访问
		for (int v = 0; v <= n; ++v) {
			//如果v未访问u能到达v
			if (vis[v] == false && G[u][v] != INF) {
				if (d[u] + G[u][v] < d[v]) {
					d[v] = d[u] + G[u][v];
					pre[v].clear();
					pre[v].push_back(u);
				}
				else if (d[u] + G[u][v] == d[v])	pre[v].push_back(u);
			}
		}
	}
}
void DFS(int v) {
	if (v == 0) {					//递归边界,叶子结点
		tempPath.push_back(v);
		//路径tempPath上需要携带的数目,需要带回的数目
		int need = 0, remain = 0;
		for (int i = tempPath.size() - 1; i >= 0; --i) {//必须要倒着枚举
			int id = tempPath[i];//当前结点编号为id
			if (weight[id] > 0)	remain += weight[id];	//点权大于0,我们需要带走多的自行车
			else {		//点权小于0,需要给这个点一部分自行车
				if (remain > abs(weight[id]))	remain -= abs(weight[id]);	
				//当前有的够补给
				else {	//当前有的不够补给
					need += abs(weight[id])-remain;
					remain = 0;
				}
			}
		}
		if (need < minNeed) {	//比较一下,那个需要的自行车少.
			minNeed = need;		//优化minNeed
			minRemain = remain;	//优化minRemain
			path = tempPath;
		}
		else if (need == minNeed && remain < minRemain) {
			//需要的自行车相同的.reamin带会来的变少了.
			minRemain = remain;	//优化需要带回的自行车
			path = tempPath;
		}
		tempPath.pop_back();
		return;
	}
	tempPath.push_back(v);
	for (int i = 0; i < pre[v].size(); ++i)	DFS(pre[v][i]);
	tempPath.pop_back();
}
int main(void) {
	scanf("%d%d%d%d", &Cmax, &n, &Sp, &m);
	int u, v;
	fill(G[0], G[0] + MAXV * MAXV, INF);
	for (int i = 1; i <= n; ++i) {
		scanf("%d", &weight[i]);
		weight[i] -= Cmax / 2;
	}
	for (int i = 0; i < m; ++i) {
		scanf("%d%d", &u, &v);
		scanf("%d", &G[u][v]);
		G[v][u] = G[u][v];
	}
	Dijkstra(0);
	DFS(Sp);
	printf("%d ", minNeed);
	for (int i = path.size() - 1; i >= 0; --i) {
		printf("%d", path[i]);
		if (i > 0)	printf("->");
	}
	printf(" %d", minRemain);
	return 0;
}

如果这篇文章对你有张帮助的话,可以用你高贵的小手给我点一个免费的赞吗

相信我,你也能变成光.

在这里插入图片描述

如果你有任何建议,或者是发现了我的错误,欢迎评论留言指出.

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值