PAT(甲级)2020年秋季考试 7-1 Panda and PP Milk (C++)

在这里插入图片描述

PP milk (盆盆奶)is Pandas’ favorite. They would line up to enjoy it as show in the picture. On the other hand, they could drink in peace only if they believe that the amount of PP milk is fairly distributed, that is, fatter panda can have more milk, and the ones with equal weight may have the same amount. Since they are lined up, each panda can only compare with its neighbor(s), and if it thinks this is unfair, the panda would fight with its neighbor.

Given that the minimum amount of milk a panda must drink is 200 ml. It is only when another bowl of milk is at least 100 ml more than its own that a panda can sense the difference.

Now given the weights of a line of pandas, your job is to help the breeder(饲养员)to decide the minimum total amount of milk that he/she must prepare, provided that the pandas are lined up in the given order.

Input Specification:

Each input file contains one test case. For each case, first a positive integer n ( ≤ 1 0 4 ) n (≤10^4) n(104) is given as the number of pandas. Then in the next line, n n n positive integers are given as the weights (in kg) of the pandas, each no more than 200. the numbers are separated by spaces.

Output Specification:

For each test case, print in a line the minimum total amount of milk that the breeder must prepare, to make sure that all the pandas can drink in peace.

Sample Input:

10
180 160 100 150 145 142 138 138 138 140

Sample Output:

3000

Hint:

The distribution of milk is the following:

400 300 200 500 400 300 200 200 200 300

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-08 13:29:44
// All rights reserved.

#include <iostream>
#include <vector>
#include <cmath>

using namespace std;

int weights[10010];
int distribute[10010];

int main(){
    int n;
    scanf("%d", &n);

    int sum = 0;
    for(int i = 0; i < n; ++i) scanf("%d", &weights[i]);

    fill(distribute, distribute + 10010, 200);
    for(int i = 1; i < n; ++i){
        if(weights[i] > weights[i - 1]) distribute[i] = distribute[i - 1] + 100;
        else if(weights[i] == weights[i - 1]) distribute[i] = distribute[i - 1];
    }

    for(int i = n - 2; i >= 0; --i){
        if(weights[i] > weights[i + 1]) distribute[i] = max(distribute[i + 1] + 100, distribute[i]);
        else if(weights[i] == weights[i + 1]) distribute[i] = max(distribute[i + 1], distribute[i]);
    }

    for(int i = 0; i < n; ++i) sum += distribute[i];
    printf("%d\n", sum);

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值