程序设计思维与实践 Week15 作业 A-ZJM与霍格沃兹

题目链接:A-ZJM与霍格沃兹

题目描述:
ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题
题库格式:[魔咒] 对应功能
背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能
ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”

Input:
首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output:
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”

Sample Input:

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output:

light the wand
accio
what?
what?

思路:
将每一个魔咒和功能分别进行哈希,然后映射到map中,魔咒和功能的哈希分别对应彼此。同时对于字符串的处理采用gets函数进行标准输入。

总结:
字符串哈希相关介绍

代码:

#include<iostream>
#include<cstring>
#include<unordered_map>
using namespace std;
const int maxn=110;
const int seed=131;
int n,op,pos;
unordered_map<unsigned long long,string>m1,m2;
char s[maxn],s1[maxn],s2[maxn],s3[maxn];
unsigned long long _hash(char s[],int length){
    unsigned long long ans=0;
    for(int i=0;i<length;i++) 
    	ans=ans*seed+s[i];
    return ans;
}
int main(){
    while(1){
        gets(s);
        if(!strcmp("@END@",s))
        	break;
        op=0;
        for(int i=1;i<(int)strlen(s);i++){
            if(s[i]==']'){
                pos=i+2;
                break;
            }
            s1[op++]=s[i];
        }
        s1[op]=0;
        unsigned long long ans1=_hash(s1,op);
        op=0;
        for(int i=pos;i<(int)strlen(s);i++)
        	s2[op++]=s[i];
        s2[op]=0;
        unsigned long long ans2=_hash(s2,op);
        m1[ans1]=(string)(s2);
        m2[ans2]=(string)(s1);
    }
    cin>>n;
    gets(s);
    while(n--){
        gets(s);
        if(s[0]=='['){
            op=0;
            for(int i=1;i<(int)strlen(s)-1;i++)
            	s3[op++]=s[i];
            s3[op]=0;
            unsigned long long ans=_hash(s3,op);
            if(m1.count(ans)) 
            	cout<<m1[ans]<<endl;
            else 
            	cout<<"what?"<<endl;
        }
        else{
            unsigned long long ans=_hash(s,(int)strlen(s));
            if(m2.count(ans)) 
            	cout<<m2[ans]<<endl;
            else 
            	cout<<"what?"<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值