A Bug's Life (有权并查集)

Background
若雨妹妹在Debug。他惊奇的发现 Bug有两种性别,异性之间才交往,他感觉很奇怪,于是要做个实验。在他的实验中,Bug们已经被从1开始编好号了。此外,Bug的性别很好辨别。
Problem
因为若雨妹妹太懒了,他懒得去分析他总结出来的bug数据。你需要根据数据判断是否存在同性恋,输入有 t 组数据,每组数据给出bug数量n, 和关系数m, 以下m行给出相交往的一对Bug编号 a, b。只需要判断有没有,按题目要求输出。

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

思路:记录当前节点到根节点的位置,从而确定性别。

#include <iostream>
#include <cstring>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;
const int MAX=1e4+5;
int f[MAX],r[MAX];                     //当前根节点,当前节点到根节点的距离 
bool flag;
int getf(int x)
{
	if(f[x]==x) return x;
	int t=getf(f[x]);
	r[x]=(r[x]+r[f[x]])&1;            //更新距离,此行代码一定要在上一行的下面,因为要确保找到根节点 
	return f[x]=t;
}
void merge(int x,int y)
{
	int t1=getf(x);
	int t2=getf(y);
	if(t1==t2)
	{
		if(r[x]==r[y])                 //根节点相同,且距离(性别)相同 
		{
			flag=false;
			return ;
		}
	}
	f[t2]=t1;
	r[t2]=(r[x]+1-r[y])&1;             //此时多加了一行,更新距离 
}
int main()
{
	int T;
	cin>>T;
	int k=0;
	while(T--)
	{
		int n,m;
		cin>>n>>m;
		for(int i=1;i<=n;i++)
		{
			f[i]=i;
			r[i]=0;
		}
		flag=true;
		int a,b;
		for(int i=1;i<=m;i++)
		{
			cin>>a>>b;
			if(flag)
			{
				merge(a,b);
			}
		}
		cout<<"Scenario #"<<++k<<":"<<endl;
		if(flag)
		{
			cout<<"No suspicious bugs found!"<<endl;
		}
		else
		{
			cout<<"Suspicious bugs found!"<<endl;
		}
		cout<<endl;                                 //注意格式 
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值