HDU:5707 Combine String(dp)

Given three strings aa, bb and cc, your mission is to check whether cc is the combine string of aa and bb.
A string cc is said to be the combine string of aa and bb if and only if cc can be broken into two subsequences, when you read them as a string, one equals to aa, and the other equals to bb.
For example, ``adebcf'' is a combine string of ``abc'' and ``def''.

Input

Input file contains several test cases (no more than 20). Process to the end of file.
Each test case contains three strings aa, bb and cc (the length of each string is between 1 and 2000).

Output

For each test case, print ``Yes'', if cc is a combine string of aa and bb, otherwise print ``No''.

Sample Input

abc
def
adebcf
abc
def
abecdf

Sample Output

Yes
No

思路:一开始模拟查找没有通过

dp[i][j] 记录的是 a的前i个和b的前j个是否能由c的前i+j个组成

 

#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 2e3 +5;
string a, b, c;
int dp[MAX][MAX];
int main()
{
    while (cin >> a >> b >> c) {
        memset(dp, 0, sizeof(dp));
        if (a.size() + b.size() != c.size()){
            cout << "No" << endl;
            continue;
        }
        dp[0][0] = 1;
        for (int i = 0; i <= a.size(); i++){
            for (int j = 0; j <= b.size(); j++){
                if (a[i] == c[i + j]){
                    dp[i + 1][j] |= dp[i][j];     //|  0|1=1 0|0=0 1|1=1,一真则真
                }
                if (b[j] == c[i +  j]){
                    dp[i][j + 1] |= dp[i][j];
                }
            }
        }
//        for (int i = 0; i <= a.size(); i++){
//            for (int j = 0; j <= b.size(); j++){
//                cout << dp[i][j] << endl;
//            }
//        }
        if (dp[a.size()][b.size()]){
            cout << "Yes" << endl;
        } else {
            cout << "No" << endl;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值