A - 统计难题 HDU - 1251----字典树模板题

第二天叫醒我的不是闹钟,是梦想!

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana
band
bee
absolute
acm

ba
b
band
abc
Sample Output
2
3
1
0

//字典树模板题走过的路径都+1,,到时候求前缀就很简单了

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=4e5+10;
int s[N][26];
int cnt[N],idx;
char ch[N];
void insert()
{
  int p=0;
  for(int i=0;i<strlen(ch);i++)
  {
    int u=ch[i]-'a';
    if(!s[p][u]) s[p][u]=++idx;
    p=s[p][u];
    cnt[p]++;
  }
}
int find()
{
  int p=0;
  for(int i=0;i<strlen(ch);i++)
  {
    int u=ch[i]-'a';
    if(!s[p][u]) return 0;
    p=s[p][u];
  //  cout<<cnt[p]<<endl;
  }
  return cnt[p];
}
int main()
{
  while(gets(ch)&&ch[0]!='\0') insert();
  while(~scanf("%s",ch))
  {

    cout<<find()<<endl;
  }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值