Telephone Wire POJ - 3612---dp+转换

Farmer John’s cows are getting restless about their poor telephone service; they want FJ to replace the old telephone wire with new, more efficient wire. The new wiring will utilize N (2 ≤ N ≤ 100,000) already-installed telephone poles, each with some heighti meters (1 ≤ heighti ≤ 100). The new wire will connect the tops of each pair of adjacent poles and will incur a penalty cost C × the two poles’ height difference for each section of wire where the poles are of different heights (1 ≤ C ≤ 100). The poles, of course, are in a certain sequence and can not be moved.

Farmer John figures that if he makes some poles taller he can reduce his penalties, though with some other additional cost. He can add an integer X number of meters to a pole at a cost of X2.

Help Farmer John determine the cheapest combination of growing pole heights and connecting wire so that the cows can get their new and improved service.

Input

  • Line 1: Two space-separated integers: N and C
  • Lines 2…N+1: Line i+1 contains a single integer: heighti

Output

  • Line 1: The minimum total amount of money that it will cost Farmer John to attach the new telephone wire.

Sample Input
5 2
2
3
5
1
4
Sample Output
15

解析:设f[i][j]:表示第i个柱子的高度为j的最小花费。
很容易想出递推方程
f[i][j]=min(f[i-1][k]+(j-a[i])^2+abs(j-k)*c);
但这是一个O(nh^2);
所以我们需要把绝对值拆开来讨论
f[i][j]=min(f[i-1][k]+c*j-c*k+(j-a[i])^2); (j>=k)
f[i][j]=min(f[i-1][k]+k*c-c*j+(j-a[i])^2); (j<=k)
我们需要正反序遍历一遍正序前要更新一下mi=min(f[i-1][k]-c*k).
正序从a[i]--100;mi=min(f[i-1][j]-c*j);
反序从100--a[i];mi=min(f[i-1][j]+c*j);

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e5+10;
int f[N][101];
int a[N];
int n,c;
int main()
{
	scanf("%d %d",&n,&c);
	for(int i=1;i<=n;i++) scanf("%d",&a[i]);
	memset(f,67,sizeof f);
	for(int i=a[1];i<=100;i++ ) f[1][i]=(i-a[1])*(i-a[1]);//预处理 
	for(int i=2;i<=n;i++)
	{
		int mi=1e9;
		for(int k=1;k<a[i];k++) mi=min(mi,f[i-1][k]-c*k); //第i-1根柱子的高度为k,因为低于i根柱子高度所以-c*k; 
		for(int j=a[i];j<=100;j++)//j>=k; 
		{
			mi=min(mi,f[i-1][j]-c*j); // 第i-1根柱子的高度为j,减去c*j 
			f[i][j]=min(f[i][j],mi+c*j+(j-a[i])*(j-a[i]));//第i根柱子的高度为j,因为j>=k; +c*j
		}
		mi=1e9;
		for(int j=100;j>=a[i];j--)// j<=k
		{
			mi=min(mi,f[i-1][j]+c*j);//第i-1根柱子的高度为j,+c*j 
			f[i][j]=min(f[i][j],mi-c*j+(j-a[i])*(j-a[i]));//第i根柱子的高度为j,因为j<=k;-c*j 
		}
	}
	int ans=0x3f3f3f3f;
	for(int i=a[n];i<=100;i++) ans=min(ans,f[n][i]);
	cout<<ans<<endl;
}
Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值