O - GCD - Extreme (II) UVA - 11426-------------------------------数论(线性欧拉筛+套路题)

Given the value of N, you will have to find the value of G. The definition of G is given below:
G =
i<N

i=1
j

≤N
j=i+1
GCD(i, j)
Here GCD(i, j) means the greatest common divisor of integer i and integer j.
For those who have trouble understanding summation notation, the meaning of G is given in the
following code:
G=0;
for(i=1;i<N;i++)
for(j=i+1;j<=N;j++)
{
G+=gcd(i,j);
}
/Here gcd() is a function that finds
the greatest common divisor of the two
input numbers
/
Input
The input file contains at most 100 lines of inputs. Each line contains an integer N (1 < N < 4000001).
The meaning of N is given in the problem statement. Input is terminated by a line containing a single
zero.
Output
For each line of input produce one line of output. This line contains the value of G for the corresponding
N. The value of G will fit in a 64-bit signed integer.
Sample Input
10
100
200000
0
Sample Output
67
13015
143295493160
题意:
在这里插入图片描述

解析:

设gcd(x,n)=i;
那么就一定有gcd( x i \frac{x}{i} ix, n i \frac{n}{i} in)=1
又因为x<n 所以存在 x i \frac{x}{i} ix< n i \frac{n}{i} in 并且 x i \frac{x}{i} ix n i \frac{n}{i} in互质
所以对答案的贡献就是φ( n i \frac{n}{i} in )

可以用线性筛求欧拉函数

又因为gcd( x i ∗ k \frac{x}{i}*k ixk, n i ∗ k \frac{n}{i}*k ink)=1*k

所以我们还要枚举k,(所以对答案的贡献不仅只有1)

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=4e6+1000;
ll f[N],s[N],n;
int prime[N],cnt;
int phi[N];
bool st[N];
void init()
{
	phi[1]=1;
	for(int i=2;i<=N;i++)
	{
		if(!st[i]) 
		{
			prime[++cnt]=i;
			phi[i]=i-1;
		}
		for(int j=1;j<=cnt&&prime[j]<=N/i;j++)
		{
			st[i*prime[j]]=true;
			if(i%prime[j]==0)
			{
				phi[i*prime[j]]=phi[i]*prime[j];
				break;
			}
			phi[i*prime[j]]=phi[i]*(prime[j]-1);
		}
	}
}
int main()
{
	init();
	for(int i=1;i<N;i++)//题目要求i<j 所以不能取到N
	{
		for(int j=i*2;j<=N;j+=i)
		{
			f[j]+=i*phi[j/i];
		//	cout<<f[j]<<endl;
		}
	}
	for(int i=1;i<=N;i++) s[i]=s[i-1]+f[i]; 
	while(~scanf("%lld",&n)&&n!=0)
	{
	//	cout<<n<<endl;
		cout<<s[n]<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值