Hdu1711 KMP算法匹配(水)

Hdu 1711 KMP算法匹配(水)

Problem Description

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample output

6
-1
------------------------- 我是分割线 ----------------------------------------------
第一反应getline()函数读取一行,于是就GG
因为getline函数会将空格也读入。按字符数用scanf()读入后,这也就是kmp匹配的模板题了。

#include <iostream>
#include<stdio.h>
#include<string>
#include<algorithm>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;
 
const int N=100005;
int Next[N];
int ps[N],ts[10*N];
void make_next(int b){
 int i=0,k=-1;
 Next[0]=k;
 while(i<b-1){
  //cout<<i<<" "<<k<<endl;
  if(k==-1||ps[i]==ps[k])Next[++i]=++k;
  else k=Next[k];
 }
}
int main() {
 int t;scanf("%d",&t);
 while(t--){
  int a,b;
  scanf("%d%d",&a,&b);
  for(int i=0;i<a;i++)scanf("%d",&ts[i]);
  for(int j=0;j<b;j++)scanf("%d",&ps[j]);
  make_next(b);
  //for(int i=0;i<b;i++)cout<<Next[i]<<" ";
  int i=0,j=0,flag=0,ans=-1;
  while(i<a){
   if(j==-1||ps[j]==ts[i]){
    i++;j++;
   }
   else j=Next[j];
   if(j==b){
    ans=i-b+1;
    break;
   }
  }
  cout<<ans<<endl;
 }
  return 0;
  /*getline(cin,ps);
  make_next();*/
}
Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值