Windows Message Queue --优先队列

题目
Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input
There’s only one test case in the input. Each line is a command, “GET” or “PUT”, which means getting message or putting message. If the command is “PUT”, there’re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output
For each “GET” command, output the command getting from the message queue with the name and parameter in one line. If there’s no message in the queue, output “EMPTY QUEUE!”. There’s no output for “PUT” command.

Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

思路:先要定义一个结构体,然后创建一个队列,priority_queue,结构体中写明顺序;
取出一个字符串,比较。
若是PUT,如果队列没有东西,输出“EMPTY QUEUE!”,如果有,就输出内容,并且让他出队列。
若是GET,存入结构体变量,进队列。

#include <iostream>
#include <cstring>
#include <queue>
#include <cstdio>
using namespace std;
struct node
{
    char name[105];
    int cs;
    int grade;
    int se;
    bool friend operator <(node a,node b)			//定义顺序
    {
        if(a.grade==b.grade)
            return a.se>a.se;
        return a.grade>b.grade;
    }
}st;				//定义的结构体
int main()
{
    char p[4];
    int gra=1;
    priority_queue<node> que;
    while(~scanf("%s",p))
    {
        if(strcmp(p,"GET")==0)
        {
            if(que.empty()) printf("EMPTY QUEUE!\n");
            else
            {
                st=que.top();				//放入结构体变量中
                que.pop();					//出队列
                printf("%s %d\n",st.name,st.cs);
            }
        }
 
        if(strcmp(p,"PUT")==0)
        {
            scanf("%s %d %d",st.name,&st.cs,&st.grade);
            st.se=gra;
            gra++;						//顺序:如果优先级相同,先进来的先出去
            que.push(st);			//进入队列
        }
    }
    return 0;
}

求赞!!!

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值