POJ 3114 Countries in War【tarjan缩点+最短路】

C o u n t r i e s   i n   W a r Countries\ in\ War Countries in War

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5132Accepted: 1494

Description

In the year 2050, after different attempts of the UN to maintain peace in the world, the third world war broke out. The importance of industrial, commercial and military secrets obliges all the countries to use extremely sophisticated espionage services, so that each city in the world has at least one spy of each country. These spies need to communicate with other spies, informers as well as their headquarters during their actions. Unluckily there doesn’t exist a secure way for a spy to communicate during the war period, therefore the messages are always sent in code so that only the addressee is able to read the message and understand its meaning.

The spies use the only service that functions during the war period, the post. Each city has a postal agency where the letters are sent. The letters can be sent directly to their destination or to other postal agencies, until the letter arrives at the postal agency of the destination city, if possible.

The postal agency in city A can send a printed letter to the postal agency in city B if there is an agreement on sending letters, which determines the time, in hours, that a letter takes to reach city B from city A (and not necessarily the opposite). If there is no agreement between the agencies A and B, the agency A can try to send the letter to any agency so that the letter can reach its destination as early as possible

Some agencies are connected with electronic communication media, such as satellites and optical fibers. Before the war, these connections could reach all the agencies, making that a letter could be sent instantly. But during the period of hostilities every country starts to control electronic communication and an agency can only send a letter to another agency by electronic media (or instantly) if they are in the same country. Two agencies, A and B, are in the same country if a printed letter sent from any one of the agencies can be delivered to the other one.

The espionage service of your country has managed to obtain the content of all the agreements on sending messages existing in the world and desires to find out the minimum time to send a letter between different pairs of cities. Are you capable of helping them?

Input

The input contains several test cases. The first line of each test case contains two integer separated by a space, N (1 ≤ N ≤ 500) and E (0 ≤ E ≤ N2), indicating the numbers of cities (numbered from 1 to N) and of agreements on sending messages, respectively. Following them, then, E lines, each containing three integers separated by spaces, X, Y and H (1 ≤ X, Y ≤ N, 1 ≤ H ≤ 1000), indicating that there exist an agreement to send a printed letter from city X to city Y, and that such a letter will be delivered in H hours.

After that, there will be a line with an integer K (0 ≤ K ≤ 100), the number of queries. Finally, there will be K lines, each representing a query and containing two integers separated by a space, O and D (1 ≤ O, D ≤ N). You must determine the minimum time to send a letter from city O to city D.

The end of the input is indicated by N = 0.

Output

For each test case your program should produce K lines of output. The I-th line should contain an integer M, the minimum time, in hours, to send a letter in the I-th query. If there aren’t communication media between the cities of the query, you should print “Nao e possivel entregar a carta” (“It’s impossible to deliver the letter”).

Print a blank line after each test case.

Sample Input

4 5
1 2 5
2 1 10
3 4 8
4 3 7
2 3 6
5
1 2
1 3
1 4
4 3
4 1
3 3
1 2 10
2 3 1
3 2 1
3
1 3
3 1
3 2
0 0
Sample Output

0
6
6
0
Nao e possivel entregar a carta

10
Nao e possivel entregar a carta
0
Source

South America 2006, Brazil Subregion

题目大意:

其实很简单
给出n个点和m条有向带权边,强连通的点之间距离视为0,给出k次询问,每次询问两个点之间最短距离,如果不能达到,输出“Nao e possivel entregar a carta”

-------------------------------------------------------------------------------------

强连通分量分解之后每次询问跑一遍单源最短路,Dijkstra+堆优化或者SPFA
如果用floyd预处理会超时

AC代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn = 555;
const int maxm = 3e5+7;
const int INF = 0x3f3f3f3f;
struct EDGE{
    int to,cost,next;
};
EDGE edge[maxm];
int n,m,top,number,index,edge_num;
int dfn[maxn],low[maxn],stk[maxn],instk[maxn],head[maxn],scc_id[maxn],mp[maxn][maxn];
void init(){
    top = number = index = edge_num = 0;
    memset(mp,INF,sizeof(mp));
    memset(head,255,sizeof(head));
    for(int i=0;i<maxn;i++) dfn[i]=low[i]=instk[i]=mp[i][i]=0;
}
void add_edge(int u,int v,int c){
    edge[edge_num].to = v;
    edge[edge_num].cost = c;
    edge[edge_num].next = head[u];
    head[u] = edge_num++;
}
void input_build(){
    init();
    for(int i=1;i<=m;i++){
        int u,v,c;
        scanf("%d %d %d",&u,&v,&c);
        add_edge(u,v,c);
    }
}
void tarjan(int u){
    dfn[u] = low[u] = ++index;
    instk[stk[++top]=u] = 1;
    for(int i=head[u];i!=-1;i=edge[i].next){
        int v = edge[i].to;
        if(!dfn[v]){
            tarjan(v);
            low[u] = min(low[u],low[v]);
        }
        else if(instk[v]) low[u] = min(low[u],dfn[v]);
    }
    if(dfn[u]==low[u]){
        ++number;
        while(stk[top]!=u){
            instk[stk[top]] = 0;
            scc_id[stk[top--]] = number;
        }
        instk[stk[top]] = 0;
        scc_id[stk[top--]] = number;
    }
}
void rebuild(){
    for(int i=1;i<=n;i++){
        for(int j=head[i];j!=-1;j=edge[j].next){
            int u = scc_id[i];
            int v = scc_id[edge[j].to];
            if(u!=v) mp[u][v] = min(mp[u][v],edge[j].cost);
        }
    }
}
int dijkstra(int st,int ed){
    int dist[maxn];
    memset(dist,INF,sizeof(dist));
    dist[st] = 0;
    priority_queue<pair<int,int> > que;
    que.push(make_pair(dist[st],st));
    while(!que.empty()){
        pair<int,int> now = que.top();
        que.pop();
        int d = now.first,pos = now.second;
        if(dist[pos]!=d) continue;
        for(int i=1;i<=number;i++) if(dist[i]>dist[pos]+mp[pos][i]){
            dist[i] = dist[pos]+mp[pos][i];
            que.push(make_pair(dist[i],i));
        }
    }
    return dist[ed];
}
void query(){
    int k;
    for(scanf("%d",&k);k;k--){
        int pa,pb;
        scanf("%d %d",&pa,&pb);
        int u = scc_id[pa],v = scc_id[pb];
        int d = dijkstra(u,v);
        if(d!=INF) printf("%d\n",d);
        else printf("Nao e possivel entregar a carta\n");
    }
}
int main(){
    while(scanf("%d %d",&n,&m)!=EOF&&n+m){
        input_build();
        for(int i=1;i<=n;i++) if(!dfn[i]) tarjan(i);
        rebuild();
        query();
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值