POJ 3114 Countries in War 缩点+最短路(好题)


Countries in War
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2001 Accepted: 626

Description

In the year 2050, after different attempts of the UN to maintain peace in the world, the third world war broke out. The importance of industrial, commercial and military secrets obliges all the countries to use extremely sophisticated espionage services, so that each city in the world has at least one spy of each country. These spies need to communicate with other spies, informers as well as their headquarters during their actions. Unluckily there doesn’t exist a secure way for a spy to communicate during the war period, therefore the messages are always sent in code so that only the addressee is able to read the message and understand its meaning.

The spies use the only service that functions during the war period, the post. Each city has a postal agency where the letters are sent. The letters can be sent directly to their destination or to other postal agencies, until the letter arrives at the postal agency of the destination city, if possible.

The postal agency in city A can send a printed letter to the postal agency in city B if there is an agreement on sending letters, which determines the time, in hours, that a letter takes to reach city B from city A (and not necessarily the opposite). If there is no agreement between the agencies A and B, the agency A can try to send the letter to any agency so that the letter can reach its destination as early as possible

Some agencies are connected with electronic communication media, such as satellites and optical fibers. Before the war, these connections could reach all the agencies, making that a letter could be sent instantly. But during the period of hostilities every country starts to control electronic communication and an agency can only send a letter to another agency by electronic media (or instantly) if they are in the same country. Two agencies, A and B, are in the same country if a printed letter sent from any one of the agencies can be delivered to the other one.

The espionage service of your country has managed to obtain the content of all the agreements on sending messages existing in the world and desires to find out the minimum time to send a letter between different pairs of cities. Are you capable of helping them?

Input

The input contains several test cases. The first line of each test case contains two integer separated by a space, N (1 ≤ N ≤ 500) and E (0 ≤ E ≤ N2), indicating the numbers of cities (numbered from 1 to N) and of agreements on sending messages, respectively. Following them, then, E lines, each containing three integers separated by spaces, XY and H (1 ≤ XY ≤ N, 1 ≤ H ≤ 1000), indicating that there exist an agreement to send a printed letter from city X to city Y, and that such a letter will be delivered in H hours.

After that, there will be a line with an integer K (0 ≤ K ≤ 100), the number of queries. Finally, there will be K lines, each representing a query and containing two integers separated by a space, O and D (1 ≤ OD ≤ N). You must determine the minimum time to send a letter from city O to city D.

The end of the input is indicated by N = 0.

Output

For each test case your program should produce K lines of output. The I-th line should contain an integer M, the minimum time, in hours, to send a letter in the I-th query. If there aren’t communication media between the cities of the query, you should print “Nao e possivel entregar a carta” (“It’s impossible to deliver the letter”).

Print a blank line after each test case.

Sample Input

4 5
1 2 5
2 1 10
3 4 8
4 3 7
2 3 6
5
1 2
1 3
1 4
4 3
4 1
3 3
1 2 10
2 3 1
3 2 1
3
1 3
3 1
3 2
0 0

Sample Output

0
6
6
0
Nao e possivel entregar a carta

10
Nao e possivel entregar a carta
0

Source

South America 2006, Brazil Subregion


题意是说在几个邮局之间传送一份信件,如果出发点和终止点在同一个国家传递,则时间为0,否则让你求花费最少时间,如果不能传到,则输出Nao e possivel entregar a carta。判断邮局是否在同一个国家的依据是发出的信件可以相互到达。
如果直接求最短路则无法判断两个邮局是否在同一个国家,判断两个邮局是否属于同一个国家的标志是在这个国家邮局间可以相互到达,那么这就是强连通了,所以要先缩点判读邮局是否在同一个国家,如果不是,则重新建图,建图的时候要维护好边权,求出最短边权,在用dijkstra求出最短路即可。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 507
#define inf 0x3f3f3f
using namespace std;
int n,m,cnt,num,id,scnt;
int g[M][M],dfn[M],low[M],stack[M];
int map[M][M],belong[M],vis[M],head[M],dis[M],viss[M];
struct E
{
    int v,next;
}edg[M*M];

void addedge(int u,int v)
{
    edg[num].v=v;
    edg[num].next=head[u];
    head[u]=num++;
}

void init()//初始化
{
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(belong,0,sizeof(belong));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            if(i!=j)
                g[i][j]=map[i][j]=inf;
            else
                g[i][j]=map[i][j]=0;
    cnt=num=scnt=id=0;
}

void tarjan(int x)//求强连通分量
{
    int v;
    dfn[x]=low[x]=++cnt;
    stack[id++]=x;
    vis[x]=1;
    for(int u=head[x];u!=-1;u=edg[u].next)
    {
        v=edg[u].v;
        if(!dfn[v])
        {
            tarjan(v);
            low[x]=min(low[x],low[v]);
        }
        else if(vis[v])
            low[x]=min(dfn[v],low[x]);
    }
    if(low[x]==dfn[x])
    {
        scnt++;
        do
        {
            v=stack[--id];
            belong[v]=scnt;
            vis[v]=0;
        }while(v!=x);
    }
}

void dijkstra(int u,int v)//求最短路
{
    int pos,minn;
    for(int i=1;i<=scnt;i++)
    {
        dis[i]=map[u][i];
        viss[i]=0;
    }
    viss[u]=1;
    dis[u]=0;
    for(int i=1;i<scnt;i++)
    {
        minn=inf;
        pos=1;
        for(int j=1;j<=scnt;j++)
            if(!viss[j]&&minn>dis[j])
            {
                minn=dis[j];
                pos=j;
            }
        viss[pos]=1;
        for(int j=1;j<=scnt;j++)
            if(!viss[j]&&dis[j]>dis[pos]+map[pos][j])
                dis[j]=dis[pos]+map[pos][j];
    }
    if(dis[v]==inf)//找不到路径
        printf("Nao e possivel entregar a carta\n");
    else
        printf("%d\n",dis[v]);
}

int main()
{
    while(scanf("%d%d",&n,&m)&&n!=0)//当n为0时,结束
    {
        init();
        int a,b,c,k;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(g[a][b]>c)
                g[a][b]=c;
            addedge(a,b);
        }
        for(int i=1;i<=n;i++)
            if(!dfn[i])
                tarjan(i);
        for(int i=1;i<=n;i++)//重新建图
            for(int j=1;j<=n;j++)
                if(i!=j&&belong[i]!=belong[j]&&g[i][j]!=inf)
                {
                    map[belong[i]][belong[j]]=min(g[i][j],map[belong[i]][belong[j]]);
                }
        scanf("%d",&k);
        while(k--)
        {
            scanf("%d%d",&a,&b);
            if(belong[a]==belong[b])//在同一个国家
                printf("0\n");
            else//不在同一个国家
                dijkstra(belong[a],belong[b]);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值