codeforce_exercise_r5

A Spy in the Metro(UVa-1025) :

问题描述

题目简述

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After
several thrilling events we find her in the first station of Algorithms City Metro, examining the time
table. The Algorithms City Metro consists of a single line with trains running both ways, so its time
table is not complicated.
Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria
knows that a powerful organization is after her. She also knows that while waiting at a station, she is
at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running
trains as much as possible, even if this means traveling backward and forward. Maria needs to know
a schedule with minimal waiting time at the stations that gets her to the last station in time for her
appointment. You must write a program that finds the total waiting time in a best schedule for Maria.
The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains
move in both directions: from the first station to the last station and from the last station back to the
first station. The time required for a train to travel between two consecutive stations is fixed since all
trains move at the same speed. Trains make a very short stop at each station, which you can ignore
for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the
trains involved stop in that station at the same time.

输入/输出格式

输入格式:
The input file contains several test cases. Each test case consists of seven lines with information as
follows.
Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations.
Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment.
Line 3. N − 1 integers: t1, t2, . . . , tN−1 (1 ≤ ti ≤ 20), representing the travel times for the trains
between two consecutive stations: t1 represents the travel time between the first two stations, t2
the time between the second and the third station, and so on.
Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first
station.
Line 5. M1 integers: d1, d2, . . . , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which
trains depart from the first station.
Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th
station.
Line 7. M2 integers: e1, e2, . . . , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which
trains depart from the N-th station.
The last case is followed by a line containing a single zero.
输出格式:
For each test case, print a line containing the case number (starting with 1) and an integer representing
the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is
unable to make the appointment. Use the format of the sample output.

样例

输入样例:
4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0

输出样例:
Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

问题分析

解题思路

通过分析题意可以看出,这个题基本上是一个DAG上的动态规划模型。可以设dp(i.j)为在第i时刻,在j车站时的最少等待的时间。这样,答案为dp(0,1),且初始化dp(T,n)为0。这样,在一个车站,可以做出3种决策:1.等待1分钟。2.向前坐一站。(如果有车的话)3.向后坐一站(如果有车的话)。
因此,可以列出状态转移方程为:
1.dp(i,j)=dp(i+1,j)+1
2.dp(i,j)=dp(i+t(j-1),j-1)
3.dp(i,j)=dp(i+t(j),j+1)
dp(i,j)取以上三种情况的最小值。
根据输入数据建图后求解即可。

参考代码
#include <iostream>
#include <cstring>

using namespace std;

const int inf=1000005;

int dp[2000][2000];
int have_train[2000][2000][2];
int times[2000];
int n,T,m1,m2;

void init()
{
	memset(dp,inf,sizeof(dp));
	memset(have_train,0,sizeof(have_train));
	memset(times,0,sizeof(times));
}

int main()
{
	int cnt=0; 
	while(scanf("%d",&n)==1&&n!=0)
	{
		init();
		scanf("%d",&T);
		for(int i=1;i<=n-1;i++)
		{
			scanf("%d",&times[i]);
		}
		scanf("%d",&m1);
		for(int i=1;i<=m1;i++)
		{
			int start_time;
			scanf("%d",&start_time);
			for(int j=0;j<n;j++)
			{
				have_train[start_time+times[j]][j+1][0]=1;
				start_time=start_time+times[j];
			}
		}
		scanf("%d",&m2);
		for(int i=1;i<=m2;i++)
		{
			int start_time;
			scanf("%d",&start_time);
			for(int j=n;j>0;j--)
			{
				have_train[start_time+times[j]][j][1]=1;
				start_time=start_time+times[j];
			}
		}
		dp[T][n]=0;
		for(int i=T-1;i>=0;i--)
		{
			for(int j=1;j<=n;j++)
			{
				dp[i][j]=dp[i+1][j]+1;
				if(j<n&&have_train[i][j][0]&&i+times[j]<=T)
				{
					dp[i][j]=min(dp[i][j],dp[i+times[j]][j+1]);
				}
				if(j>1&&have_train[i][j][1]&&i+times[j-1]<=T)
				{
					dp[i][j]=min(dp[i][j],dp[i+times[j-1]][j-1]);
				}
			}
		}
		printf("Case Number %d: ",++cnt);
		if(dp[0][1]>=inf) printf("impossible\n");
		else printf("%d\n",dp[0][1]);
	}
	return 0;
} 

心得体会

DAG动态规划模型的练习题。这个题的dp变量设计有一些难想,我在这一点上想了很长时间,也看了书上的解析。然后在写程序的时候感觉不是很顺利,反正还是要多加练习。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值