POJ 2478 Farey Sequence

传送门:http://poj.org/problem?id=2478
Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.
Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input

2
3
4
5
0
Sample Output

1
3
5
9

题意

  给你一个数m,问你<m,且与m互质的数的个数

思路

  欧拉函数,n比较大,快速打表……

#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<vector>
#include<stack>
#include<queue>
#include<ctime>
#define ll long long
#define ld long double
#define ull unsigned long long
using namespace std;
const int maxn = 1000010;
const int inf = 0x3f3f3f3f3f;
const ll lnf = 0x3f3f3f3f3f3f3f;
const ll mod =  1000000007;
int pri[maxn],tot;
int phi[maxn];
bool v[maxn];
void euler()
{
    memset(v,true,sizeof(v));
    v[1] = false;
    tot = 0;
    for(int i=2;i<maxn;i++){
        if(v[i]){
            pri[++tot] = i;
            phi[i] = i-1;	//欧拉函数性质一,i是质数
        }
        for(int j=1;j<=tot&&i*pri[j]<maxn;j++){
            v[i*pri[j]] = false;
            if(i%pri[j]==0){
                phi[i*pri[j]] = phi[i] * pri[j];	//欧拉函数性质二,pri[j]|i
                break;
            }
            phi[i*pri[j]] = phi[i] * phi[pri[j]];	//欧拉函数性质二,gcd(i,pri[j])=1
        }
    }
}
int main(void)
{
    int n;
    ll ans = 0;
    euler();
    while(scanf("%d",&n),n){
        ans = 0;
        for(int i=2;i<=n;i++){
            ans += (ll)phi[i];
        }
        printf("%lld\n",ans);
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

逃夭丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值