POJ 2891 + POJ 2115

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:
Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai, ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

Line 1: Contains the integer k.
Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ i ≤ k).
Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9
Sample Output

31

拓展CRT模板
#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<ctime>
#define ll long long
#define ld long double
#define ull unsigned long long
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 100100;
int n;
ll m[maxn],c[maxn];
ll gcd(ll a,ll b){
    return b==0 ? a:gcd(b,a%b);
}
ll mul(ll x,ll y,ll z){
    ll sm = (ld)x/z*y;
    return ((ull)x*y-(ull)sm*z+z)%z;
}
ll exgcd(ll a,ll b,ll &x,ll &y){
    if(b==0){
        x = 1;
        y = 0;
        return a;
    }
    ll g = exgcd(b,a%b,y,x);
    y -= a/b * x;
    return g;
}
ll inv(ll a,ll b){
    ll x,y;
    ll g = exgcd(a,b,x,y);
    ll tp = b/g;
    x = (x%tp+tp)%tp;
    return x;
}
ll excrt()
{
    for(int i=2;i<=n;i++){
        ll m1 = m[i-1], m2 = m[i];
        ll c2 = c[i], c1 = c[i - 1];
        ll T = gcd(m1,m2);

        if((c2-c1)%T)   return -1;

        m[i] = m1/T*m2;

        c[i] = mul(inv(m1/T,m2/T),(c2-c1)/T,(m2/T))*m1+c1;

        c[i] = (c[i]%m[i]+m[i])%m[i];
    }
    return c[n];
}
int main(void)
{
    while(~scanf("%d",&n)){
        for(int i=1;i<=n;i++){
            scanf("%lld%lld",&m[i],&c[i]);
            c[i] = (c[i]%m[i]+m[i])%m[i];
        }
        ll ans = excrt();
        printf("%lld\n",ans);
    }
    return 0;
}

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37020 Accepted: 10896
Description

A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C)

statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.
Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0
Sample Output

0
2
32766
FOREVER

思路

(A+Cx) % K = B
A + Cx = B + Ky
Cx + Ky = B-A
拓展欧几里得

#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<ctime>
#define ll long long
#define ld long double
#define ull unsigned long long
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 100100;
ll exgcd(ll a,ll b,ll &x,ll &y){
    if(b==0){
        x = 1;
        y = 0;
        return a;
    }
    ll g = exgcd(b,a%b,y,x);
    y -= a/b * x;
    return g;
}
int main(void)
{
    ll A,B,C,K;
    while(1){
        scanf("%lld%lld%lld%lld",&A,&B,&C,&K);
        if(A==0&&B==0&&C==0&&K==0)  break;
        ll a = C,c = B-A;
        ll b = 1;
        for(ll i=1;i<=K;i++)
            b *= 2;
        ll x,y;
        ll g = exgcd(a,b,x,y);
        if(c%g!=0)  printf("FOREVER\n");
        else{
            x = c*x/g;
            if(x>=0)    x = x%(b/g);
            else    x = x%(b/g)+b/g;
            printf("%lld\n",x);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

逃夭丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值