J - Tempter of the Bone

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
 The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
  ‘X’: a block of wall, which the doggie cannot enter;
  ‘S’: the start point of the doggie;
  ‘D’: the Door; or
  ‘.’: an empty block.
The input is terminated with three 0’s. This test case is not to be processed.
Output
 For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.
Sample Input
4 4 5
S.X.
…X.
…XD

3 4 5
S.X.
…X.
…D
0 0 0
Sample Output
NO
YES

方法一:
  暴力搜索:

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>

using namespace std;
int n,m,k;
bool ans;
char nmb[10][10];
bool p[10][10];
int op[4][2]={{0,1},{1,0},{-1,0},{0,-1}};
void DFS(int x,int y,int t){
    if(t>k)
        return ;
    else if(nmb[x][y]=='D'&&t==k){
        ans = true;
        return ;
    }
    else if(nmb[x][y]=='.'||nmb[x][y]=='S'){
        p[x][y] = false;
        if(y+1<m&&p[x][y+1]) DFS(x,y+1,t+1);
        if(y-1>=0&&p[x][y-1]) DFS(x,y-1,t+1);
        if(x+1<n&&p[x+1][y]) DFS(x+1,y,t+1);
        if(x-1>=0&&p[x-1][y]) DFS(x-1,y,t+1);
        p[x][y] = true;

    }
}
int main(void)
{
    while(scanf("%d%d%d",&n,&m,&k)&&(n+m+k)){
        int x,y;
        char num;
        ans = false;
        for(int i=0;i<n;i++)
            scanf("%s",nmb[i]);
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(nmb[i][j]=='S'){
                    x = i;
                    y = j;
                    p[i][j] = false;
                }
                else p[i][j] = true;
            }
        }
        DFS(x,y,0);
        if(ans==true)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

方法二:
  奇偶剪枝+搜索
奇偶剪枝结论:
  假设起点坐标:( sx , sy );终点坐标: ( ex , ey );
若 t-[abs(ex-sx)+abs(ey-sy)]
结果为非偶数(奇数),则无法在t步恰好到达;
反之亦反。

只需要找出S和D的坐标,然后在搜索中添加下列代码:

int temp = k-t-abs(ex-sx)-abs(ey-sy)
if(temp<0||(temp&1))
	return ;
#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>

using namespace std;
int n,m,k;
int ex,ey,sx,sy;
int flag;	//记录一下是否找到最短路
bool ans;
char nmb[10][10];
bool p[10][10];
int op[4][2]={{0,1},{1,0},{-1,0},{0,-1}};
void DFS(int x,int y,int t){
    int temp = k-t-abs(ex-x)-abs(ey-y);
    if(temp<0||temp&1)
        return ;
    if(flag)	//flag == 1 表示找到,返回
        return ;
    if(nmb[x][y]=='D'&&t==k){
        ans = true;
        flag = 1;
        return ;
    }
    if(nmb[x][y]=='.'||nmb[x][y]=='S'){
        p[x][y] = false;
        if(y+1<m&&p[x][y+1]) DFS(x,y+1,t+1);
        if(y-1>=0&&p[x][y-1]) DFS(x,y-1,t+1);
        if(x+1<n&&p[x+1][y]) DFS(x+1,y,t+1);
        if(x-1>=0&&p[x-1][y]) DFS(x-1,y,t+1);
        p[x][y] = true;

    }
}
int main(void)
{
    while(scanf("%d%d%d",&n,&m,&k)&&(n+m+k)){
        char num;
        ans = false;
        flag = 0;
        for(int i=0;i<n;i++)
            scanf("%s",nmb[i]);
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(nmb[i][j]=='S'){
                    sx = i;
                    sy = j;
                    p[i][j] = false;
                }
                else{
                     p[i][j] = true;
                     if(nmb[i][j]=='D'){
                        ex = i;
                        ey = j;
                     }
                }
            }
        }
        DFS(sx,sy,0);
        if(ans==true)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

逃夭丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值