B - Tempter of the Bone

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

肯定用dfs,方法就是回溯,不过此题的关键在于剪枝,要不然就会超时,而满足剪枝的有以下几个条件

     第一  ,  已经确定了能在T时刻到达出口

     第二  ,  到达一坐标的时间超过了T时刻

     第三    ,  已经到达了出口,但是还未到T时刻

      第四  ,   已经走过了

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include <bits/stdc++.h>

using namespace std;

const int MAXN=10;
char s[MAXN][MAXN];
int vis[MAXN][MAXN];
int d[4][2]={0,1,0,-1,1,0,-1,0};
int n,m,t;
bool f;
void dfs(int x,int y,int res)
{
    // 以下是针对以上四种情况的剪枝
    if(res==t&&s[x][y]=='D'){   
        f=true;     // 表示已经确定T时刻能到
        return ;
    }
    if(res>t)return ;   // 大于 T时刻
    if(f)return ;
    if(s[x][y]=='D')return ;
    for(int i=0;i<4;i++){
        int nx=x+d[i][0],ny=y+d[i][1];
        if(nx>=0&&nx<n&&ny>=0&&ny<m&&vis[nx][ny]&&s[nx][ny]!='X'){
            vis[nx][ny]=0;
            dfs(nx,ny,res+1);
            vis[nx][ny]=1;
        }
    }
}
int main()
{
    int i,j;
    while(~scanf("%d%d%d",&n,&m,&t)){
        if(n==0&&m==0&&t==0)break;
        f=false;
        memset(vis,1,sizeof(vis));
        for(i=0;i<n;i++)
            scanf("%s",s[i]);
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            if(s[i][j]=='S'){
                vis[i][j]=0;
                dfs(i,j,0);
                break;
            }
        if(f)printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值