The Bucket List [洛谷] (贪心) /*rank*/

原题传送门


题面:

The Bucket List

                    time limit per test 1 second
                 memory limit per test 256 megabytes
                        input standard input
                       output standard output

Problem Description

Farmer John is considering a change in how he allocates buckets for milking his cows. He thinks this will ultimately allow him to use a small number of total buckets, but he is not sure how many exactly. Please help him out! Farmer John has N cows (1≤N≤100), conveniently numbered 1…N. The ith cow needs to be milked from time si to time ti, and requires bi buckets to be used during the milking process. Several cows might end up being milked at the same time; if so, they cannot use the same buckets. That is, a bucket assigned to cow i′s milking cannot be used for any other cow’s milking between time si and time ti. The bucket can be used for other cows outside this window of time, of course. To simplify his job, FJ has made sure that at any given moment in time, there is at most one cow whose milking is starting or ending (that is, the si’s and ti’s are all distinct).
FJ has a storage room containing buckets that are sequentially numbered with labels 1
, 2, 3, and so on. In his current milking strategy, whenever some cow (say, cow i) starts milking (at time si), FJ runs to the storage room and collects the bi buckets with the smallest available labels and allocates these for milking cow i.
Please determine how many total buckets FJ would need to keep in his storage room in order to milk all the cows successfully.

Input

The first line of input contains N. The next N lines each describe one cow, containing the numbers si, ti, and bi, separated by spaces. Both si and ti are integers in the range 1…1000, and bi is an integer in the range 1…10.

Output

Output a single integer telling how many total buckets FJ needs.

Sample Input

3
4 10 1
8 13 3
2 6 2

Sample Output

4

题意描述

每个牛可以产出不同数量的奶,相应的要不同数量的挤奶器,同时挤奶时间也不都相同.求出所用挤奶器能满足奶牛需求的最小数量.

题目分析

简单的贪心,只要挤奶器的数量是1-1000时间内最大值即可满足需求.

具体代码

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
struct node
{
    int s, t, b;
};
node cow[105];

bool cmp1(node a, node b)
{
    if(a.s > b.s)
    {
        return 0;
    }
}

int main()
{
    int n;
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        scanf("%d%d%d", &cow[i].s, &cow[i].t, &cow[i].b);
    }
    int ans = 0;
    for(int i = 1; i <= 1000; i++)
    {
        int temp = 0;
        for(int j = 0; j < n; j++)
        {
            if(i <= cow[j].t && i >= cow[j].s)
            {
                temp += cow[j].b;
            }
        }
        ans = max(ans, temp);
    }
    printf("%d\n", ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值