Out of sort II [洛谷] (算法理解) /*rank*/

原题传送门


题面:

Out of sort II

                              time limit per test : 1 second
                           memory limit per test : 256 megabytes
                                   input : standard input
                                  output : standard output

Problem Description

Keeping an eye on long term career possibilities beyond the farm, Bessie the cow has started learning algorithms from various on-line coding websites.

Her favorite algorithm thus far is “bubble sort”. Here is Bessie’s initial implementation, in cow-code, for sorting an array A of length N.

sorted = false

while (not sorted):

sorted = true

moo

for i = 0 to N-2:

if A[i+1] < A[i]:

     swap A[i], A[i+1]

     sorted = false

Apparently, the “moo” command in cow-code does nothing more than print out “moo”. Strangely, Bessie seems to insist on including it at various points in her code.

After testing her code on several arrays, Bessie learns an interesting observation: while large elements can be pulled to the end of the array very quickly, it can take small elements a very long time to “bubble” to the front of the array (she suspects this is how the algorithm gets its name). In order to try and alleviate this problem, Bessie tries to modify her code so that it scans forward and then backward in each iteration of the main loop, so that both large and small elements have a chance to be pulled long distances in each iteration of the main loop. Her code now looks like this:
sorted = false

while (not sorted):

sorted = true

moo

for i = 0 to N-2:

  if A[i+1] < A[i]:

     swap A[i], A[i+1]

for i = N-2 downto 0:

  if A[i+1] < A[i]:

     swap A[i], A[i+1]

for i = 0 to N-2:

  if A[i+1] < A[i]

     sorted = false

Given an input array, please predict how many times “moo” will be printed by Bessie’s modified code.

Input

The first line of input contains N (1≤N≤100,000). The next N lines describe A[0]…A[N−1], each being an integer in the range 0…1e9. Input elements are not guaranteed to be distinct.

Output

Print the number of times “moo” is printed.

Sample Input

5
1
8
5
3
2

Sample Output

2

题意描述

一个双向冒泡排序,求对给定数组的swap的执行次数.

题目分析

一个正向排序是将一个原本在前面,排序后在后面的数往后移动.一个逆向排序是将一个原本在后面,排序后在前面的数往前移动.

思路可以正向也可以反向.

正向:若排序后当前数的原本位置位于当前位置的后面,说明该数是从后面来到当前位置.那么cnt+1,同时对当前数的原本位置打上访问标记,但是如果当前数的当前位置是已访问状态时,说明当前数是位于之前排序的数的前面,那么cnt-1(去除重复),然后moo = max(cnt , moo),再对下一个数进行同样处理.

反向:若排序后当前数的原本位置位于当前位置的前面,说明该数是从前面来到当前位置,那么cnt+1,同时对当前数的原本位置打上访问标记,但如果当前数的当前位置是已访问状态时,说明当前数是位于之前排序的数的后面,那么cnt-1(去重),然后moo = max(moo , cnt),接着对下一个数做同样处理.

具体代码

正向
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+5;

struct node
{
    int num , cnt;
};
node cow[maxn];

bool cmp(node A, node B)
{
    if(A.num != B.num) return A.num < B.num;
    return A.cnt < B.cnt;
}

bool vis[maxn];

int main()
{
    int N;
    cin >> N;
    for(int i = 1; i <= N; i++)
    {
        cin >> cow[i].num;
        cow[i].cnt = i;
    }
    sort(cow+1 , cow+1+N , cmp);
    int cnt = 0, ans = 1;
    for(int i = 1; i <= N; i++)
    {
        if(cow[i].cnt > i)
        {
            cnt++;
        }
        if(vis[i])
        {
            cnt--;
        }
        vis[cow[i].cnt] = true;
        ans = max(cnt , ans);
    }
    cout << ans << endl;
    return 0;
}
反向
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+5;

struct node
{
    int num , cnt;
};
node cow[maxn];

bool cmp(node A, node B)
{
    if(A.num != B.num) return A.num < B.num;
    return A.cnt < B.cnt;
}

bool vis[maxn];

int main()
{
    int N;
    cin >> N;
    for(int i = 1; i <= N; i++)
    {
        cin >> cow[i].num;
        cow[i].cnt = i;
    }
    sort(cow+1 , cow+1+N , cmp);
    int cnt = 0, ans = 1;
    for(int i = N; i >= 1; i--)
    {
        if(cow[i].cnt < i)
        {
            cnt++;
        }
        if(vis[i])
        {
            cnt--;
        }
        vis[cow[i].cnt] = true;
        ans = max(cnt , ans);
    }
    cout << ans << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
蛋白质是生物体中普遍存在的一类重要生物大分子,由天然氨基酸通过肽键连接而成。它具有复杂的分子结构和特定的生物功能,是表达生物遗传性状的一类主要物质。 蛋白质的结构可分为四级:一级结构是组成蛋白质多肽链的线性氨基酸序列;二级结构是依靠不同氨基酸之间的C=O和N-H基团间的氢键形成的稳定结构,主要为α螺旋和β折叠;三级结构是通过多个二级结构元素在三维空间的排列所形成的一个蛋白质分子的三维结构;四级结构用于描述由不同多肽链(亚基)间相互作用形成具有功能的蛋白质复合物分子。 蛋白质在生物体内具有多种功能,包括提供能量、维持电解质平衡、信息交流、构成人的身体以及免疫等。例如,蛋白质分解可以为人体提供能量,每克蛋白质能产生4千卡的热能;血液里的蛋白质能帮助维持体内的酸碱平衡和血液的渗透压;蛋白质是组成人体器官组织的重要物质,可以修复受损的器官功能,以及维持细胞的生长和更新;蛋白质也是构成多种生理活性的物质,如免疫球蛋白,具有维持机体正常免疫功能的作用。 蛋白质的合成是指生物按照从脱氧核糖核酸(DNA)转录得到的信使核糖核酸(mRNA)上的遗传信息合成蛋白质的过程。这个过程包括氨基酸的活化、多肽链合成的起始、肽链的延长、肽链的终止和释放以及蛋白质合成后的加工修饰等步骤。 蛋白质降解是指食物中的蛋白质经过蛋白质降解酶的作用降解为多肽和氨基酸然后被人体吸收的过程。这个过程在细胞的生理活动中发挥着极其重要的作用,例如将蛋白质降解后成为小分子的氨基酸,并被循环利用;处理错误折叠的蛋白质以及多余组分,使之降解,以防机体产生错误应答。 总的来说,蛋白质是生物体内不可或缺的一类重要物质,对于维持生物体的正常生理功能具有至关重要的作用。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值