Rest stop [洛谷] (贪心) /*rank*/

原题传送门


题面:

Rest Stops

                               time limit per test : 1 second
                            memory limit per test : 256 megabytes
                                  input : standard input
                                 output : standard output

Problem Description

Farmer John and his personal trainer Bessie are hiking up Mount Vancowver. For their purposes (and yours), the mountain can be represented as a long straight trail of length L meters (1≤L≤1e6). Farmer John will hike the trail at a constant travel rate of rF seconds per meter (1≤rF≤1e6). Since he is working on his stamina, he will not take any rest stops along the way.

Bessie, however, is allowed to take rest stops, where she might find some tasty grass. Of course, she cannot stop just anywhere! There are N rest stops along the trail (1≤N≤1e5); the i-th stop is xi meters from the start of the trail (0<xi<L) and has a tastiness value ci (1≤ci≤1e6). If Bessie rests at stop i for t seconds, she receives ci⋅t tastiness units.

When not at a rest stop, Bessie will be hiking at a fixed travel rate of rB seconds per meter (1≤rB≤1e6). Since Bessie is young and fit, rB is strictly less than rF.

Bessie would like to maximize her consumption of tasty grass. But she is worried about Farmer John; she thinks that if at any point along the hike she is behind Farmer John on the trail, he might lose all motivation to continue!

Help Bessie find the maximum total tastiness units she can obtain while making sure that Farmer John completes the hike.

Input

The first line of input contains four integers: L, N, rF, and rB. The next N lines describe the rest stops. For each i between 1 and N, the i+1-st line contains two integers xi and ci, describing the position of the i-th rest stop and the tastiness of the grass there.

It is guaranteed that rF>rB, and 0<x1<…<xN<L. Note that rF and rB are given in seconds per meter!

Output

A single integer: the maximum total tastiness units Bessie can obtain.

Sample Input

10 2 4 3
7 2
8 1

Sample Output

15

题意描述

追及问题 .两个质点(牛和农夫),质点C运动快(牛),质点F运动慢(农夫),在运动过程中,质点C可以在某些地方停下并按照暂停时间获得一定的值,但质点C必须在质点F前面或者和质点F处于同一个位置.要求出质点C能够按照上述要求完成运动且能获取值的最大值.

题目分析

贪心,题目会给很多不同的暂停点和它们的值,为了取得最大,需要求出一个各个暂停点能获取的值最大,且暂停点尽量多的方案,所以对所给的暂停点进行排序.首先需要比较获取值,获取越大的越优先,其次就是按照距离排序,距离起点越近的越优先.然后按照这个方案求出来的值就是所能获取的最大值.
(题目给的速度是s/m,而不是m/s,惨痛的读题教训 )

具体代码

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+5;
typedef long long int ll;
typedef pair < ll , ll > pll;
pll Grass[maxn];
bool cmp(pll a, pll b)
{
    if(a.second != b.second)
    {
        return a.second > b.second;
    }
    return a.first < b.first;
}
int main()
{
    ll L, N, rf, rb;
    scanf("%I64d%I64d%I64d%I64d", &L, &N, &rf, &rb);
    for(ll i = 1; i <= N; i++)
    {
        scanf("%I64d%I64d", &Grass[i].first, &Grass[i].second);
    }
    sort(Grass+1, Grass+1+N, cmp);
    ll area = 0;
    ll ans = 0;
    for(ll num = 1; num <= N; num++)
    {
        if(Grass[num].first >= area)
        {
            ans += Grass[num].second*(rf-rb)*(Grass[num].first-area);
            area = Grass[num].first;
        }
    }
    printf("%I64d\n", ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值