POJ 2796 Feel Good (单调栈)

原题传送门


题面:

Feel GoodTime

                          Limit: 3000MS		Memory Limit: 65536K

Problem Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people’s memories about some period of life.

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill’s life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, … an ranging from 0 to 1e6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill’s life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill’s life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

题面描述

Bill把人每天生活的情绪离散化了,得到了n个数字代表了人在这n天内的情绪好坏(越大代表情绪越好).而Bill认为一个人在一段时间的情绪代表值应该用该段时间的最小值乘于这段时间的情绪总和.现在他想要得到这n天内情绪代表值的最大值.

题目分析

一段时间的最小值.若当天是某段时间的最小值,那么应当是从当天向前和后拓展,直到区间前和区间后一天的值比当天小.而如果枚举每一天作为最小值去拓展从而得到答案,因为数据范围是1e5,所以是不能暴力解决的.应该用单调栈来处理这个问题.
具体过程:若当天的值比前一天的值要小,更新当天所在的区间(用栈内top的左端更新当天的左端),然后加入栈内.若当天的值比前一天的值要大说明当天作为最小值的时间段的左端已经到达了,要将已入栈的值中比当天值要大的值都退出栈,同时要计算退出栈的值作为最小值和时间段内值的总和的乘积.直到最后一天的值.(在计算区间和方面应该用一个数组储存day[1]~day[i]的和,然后作差得到当天作为最小值的区间的和)

具体代码

#include <iostream>
#include <stdio.h>
#include <stack>
using namespace std;
typedef long long int ll;
const int maxn = 1e5+5;
const int inf = 0x3f3f3f3f;

struct node
{
    int num , lef;
};

ll sum[maxn];
int lef[maxn];
int stk[maxn];
int arr[maxn];
int n;

int main()
{
    sum[0] = 0;

    scanf("%d", &n);
    for(int i = 1; i <= n; i++)
    {
        scanf("%d", &arr[i]);
        sum[i] = sum[i-1]+arr[i];
    }

    arr[n+1] = -1;
    ll ans = -1;
    int al , ar , top = 0;

    for(int i = 1; i <= n+1; i++)
    {
        if(!top || arr[i] > arr[stk[top-1]])
        {
            stk[top] = i;
            lef[stk[top]] = i;
            top++;

            continue;
        }

        if(arr[i] == arr[stk[top-1]])
        {
            continue;
        }

        while(top && arr[i] < arr[stk[top-1]])
        {
            top--;
            ll TempAns = arr[stk[top]]*(sum[i-1]-sum[lef[stk[top]]-1]);

            if(TempAns > ans)
            {
                ans = TempAns, al = lef[stk[top]], ar = i-1;
            }
        }

        lef[i] = lef[stk[top]];
        stk[top] = i;
        top++;
    }

    printf("%lld\n", ans);
    printf("%d %d\n", al , ar);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值