【题解】【AcWing】1497. 树的遍历

1497. 树的遍历

原题传送:AcWing 1497. 树的遍历

一个二叉树,树中每个节点的权值互不相同。

现在给出它的后序遍历和中序遍历,请你输出它的层序遍历。

输入格式

第一行包含整数 N N N ,表示二叉树的节点数。

第二行包含 N N N 个整数,表示二叉树的后序遍历。

第三行包含 N N N 个整数,表示二叉树的中序遍历。

输出格式

输出一行 N N N 个整数,表示二叉树的层序遍历。

数据范围

1 ≤ N ≤ 30 1 \le N \le 30 1N30

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
思路:

后序遍历和中序遍历构造树,然后bfs进行层序遍历。

题解:
#include<bits/stdc++.h>

using namespace std;

const int N = 40;

int n;
int postorder[N], inorder[N];
unordered_map<int, int> l, r, pos;
int q[N];

int build(int il, int ir, int pl, int pr)
{
	int root = postorder[pr];
	int k = pos[root];
	if(il < k)
		l[root] = build(il, k - 1, pl, pl + (k - 1 - il));
	if(k < ir)
		r[root] = build(k + 1, ir, pl + (k - 1 - il) + 1, pr - 1);
	return root;
}

void bfs(int root)
{
	int hh =  0, tt = 0;
	q[0] = root;
	
	while(hh <= tt)
	{
		int t = q[hh++];
		if(l.count(t))
			q[++tt] = l[t];
		if(r.count(t))
			q[++tt] = r[t];
	}
	
	cout << q[0];
	for(int i = 1; i < n; i++)
		cout << " " << q[i];
	cout << endl;
}

int main()
{	
	cin >> n;
	
	for(int i = 0; i < n; i++)
		cin >> postorder[i];
	for(int i = 0; i < n; i++)
	{
		cin >> inorder[i];
		pos[inorder[i]] = i;
	}
		
	int root = build(0, n - 1, 0, n - 1);
	
	bfs(root);
	
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值