PTA 树的遍历 题解

题目链接

题目大意
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例

4 1 6 3 5 7 2

在这里插入图片描述
二叉树的先序遍历方式:根左右
二叉树的中序遍历方式:左根右
二叉树的后序遍历方式:左右根
二叉树任意两种遍历方式可以确定这棵树的形态

#include <bits/stdc++.h>
using namespace std;
const int maxn = 127;
struct node{
    int l,r;
}tree[maxn];

int post[maxn];
int in[maxn];
int build(int l, int r, int x, int y)  //[l,r] post [x,y] In
{
    if(l > r || x > y) return 0;
    int pos = x;
    while(in[pos] != post[r]) pos++;
    
    int len = pos - x;
    tree[post[r]].l = build(l,l+len-1,x,pos-1);  //Left
    tree[post[r]].r = build(l+len,r-1,pos+1,y); //Right
    
    return post[r];
}
int main()
{
    int p;
    cin>>p;
    for(int i = 1; i <= p; i++) cin>>post[i];
    for(int i = 1; i <= p; i++) cin>>in[i];
    
    int rt = build(1,p,1,p);
    cout<<rt;
    queue<int> q;
    if(tree[rt].l)
        q.push(tree[rt].l);
    if(tree[rt].r)
        q.push(tree[rt].r);

    while(!q.empty())
    {
        int k = q.front(); q.pop();
        cout<<' '<<k;
        if(tree[k].l)
            q.push(tree[k].l);
        if(tree[k].r)
            q.push(tree[k].r);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

幸愉聊信奥

谢谢亲的支持,我会继续努力啦~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值