1001 A+B Format

题目链接

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −1e6≤a,b≤1e6
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

大致题意
计算a+b的值,结果从后到前每三位一个逗号

具体思路
这题可以转字符串也可以直接循环从头输出,不过要先计算这个sum有几位数,根据第几位的后面需要逗号进行输出

#include<bits/stdc++.h>
using namespace std;
typedef long long int LLD;
int main()
{
    LLD a,b;
    scanf("%lld %lld",&a,&b);
    LLD sum=a+b;
    if (sum<0)
    {
        printf("-");
        sum=abs(sum);
    }
    LLD num=sum,flag=0;
    if (sum==0)
    {
        printf("0");
        return 0;
    }
    while (num>0)
    {
        num=num/10;
        flag++;
    }
    while (flag>0)
    {
        printf("%lld",sum/((LLD)(pow(10,flag-1)+0.1))%10);
        if (flag>3&&flag%3==1)
        {
            printf(",");
        }
        flag--;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值