1002 A+B for Polynomials

题目链接

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
在这里插入图片描述
where K is the number of nonzero terms in the polynomial,
在这里插入图片描述
are the exponents and coefficients, respectively. It is given that
在这里插入图片描述
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 2 1.5 1 2.9 0 3.2

大致题意
两行分别输入 k ,接下来2*k个数分别表示多项式指数和系数,第一输出还有几个数,之后输出两行多项式总和,指数由大到小,系数为0不需要输出

具体思路
有点类似桶排序的标记原理,将指数作为数组标记,系数累加,下面做法的空间较大,有兴趣的可以用vector进行优化

#include<bits/stdc++.h>
using namespace std;
typedef long long int LLD;
int main()
{
    double N[1005];
    memset(N,0,sizeof(N));
    LLD k;
    scanf("%lld",&k);
    while (k--)
    {
        LLD Ni;
        double An;
        scanf("%lld %lf",&Ni,&An);
        N[Ni]+=An;
    }
    scanf("%lld",&k);
    while (k--)
    {
        LLD Ni;
        double An;
        scanf("%lld %lf",&Ni,&An);
        N[Ni]+=An;
    }
    LLD num=0,MIN=1000;
    for (LLD i=1000; i>=0; i--)
    {
        if (N[i]!=0)
        {
            num++;
            MIN=i;
        }
    }
    printf("%lld",num);
    if (num!=0)
        printf(" ");
    for (LLD i=1000; i>=MIN; i--)
    {
        if (N[i]!=0.0)
        {
            printf("%lld %.1lf",i,N[i]);
            if (i!=MIN)
            {
                printf(" ");
            }
        }

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值