A+B for Polynomials

1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

本题考察的是两个多项式相加的问题。关键方法是自定义两个int类型的iterator,在连个多项式数组中同时遍历,按顺序一次合并各项。

#include <iomanip>控制流头文件包含方法:

setprecision(n),设置输出变量的精度。

#include <iostream>
#include <vector>
#include <iomanip>

using namespace std;

vector<int> exponents1, exponents2, resultExp;
vector<double> coeffients1, coeffients2, resultCoe;
int terms1, terms2;

int main() {
	int exponent;
	double coeffient;
	cin >> terms1;
	for (int i = 0; i < terms1; i++)
	{
		cin >> exponent >> coeffient;
		exponents1.push_back(exponent);
		coeffients1.push_back(coeffient);
	}
	cin >> terms2;
	for (int i = 0; i < terms2; i++)
	{
		cin >> exponent >> coeffient;
		exponents2.push_back(exponent);
		coeffients2.push_back(coeffient);
	}

	int it1=0, it2=0;
	for (; it1 < terms1 || it2 < terms2;)
	{
		if (it1<terms1 && (it2>=terms2 ||  exponents1[it1]>exponents2[it2]))
		{
			resultExp.push_back(exponents1[it1]);
			resultCoe.push_back(coeffients1[it1]);
			it1++;
		}
		else if (it2<terms2 && (it1 >= terms1 || exponents1[it1]<exponents2[it2]))
		{
			resultExp.push_back(exponents2[it2]);
			resultCoe.push_back(coeffients2[it2]);
			it2++;
		}
		else if (it1<terms1 && it2 < terms2 && exponents1[it1] == exponents2[it2])
		{
			coeffient = coeffients1[it1] + coeffients2[it2];
			if (coeffient!=0)
			{
				resultExp.push_back(exponents1[it1]);
				resultCoe.push_back(coeffient);
			}
			it1++;
			it2++;
		}
	}
	cout << fixed;
	cout << resultCoe.size();
	if (resultCoe.size()==0)
	{
		return 0;
	}
	cout << " ";
	for (int i = 0; i < resultCoe.size()-1; i++)
	{
		cout << resultExp[i] << " ";
		cout << setprecision(1) << resultCoe[i] << " ";
	}
	cout << resultExp.back() << " " << setprecision(1) << resultCoe.back();
	//cout << endl;
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值