POJ 2752 Seek the Name, Seek the Fame

题目链接

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

大致题意
给你一个字符串,求前缀后缀相同的串,输出这些串的长度

大致思路
kmp的next数组的灵活运用,求出next数组之后,从后往前寻找,最后一位的next值 x 其实就是前缀和后缀相同的一个字符串长度,超出x的部分其实就已经被排除出去了,接下来吧1到x位置的字符串看成一个整体,一样的从后面开始找,找到当前字符串前缀和后缀相同的一个字符串,以此类推,直到next为0时候,就表示没有相同的前后缀了

#include<stdio.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int max_str=4e5+50;
int next_num[max_str];
char str[max_str];
void getnext(int n)
{
    next_num[1]=0;
    int pos=0;
    for (int i=2; i<=n; i++)
    {
        while (pos!=0&&str[pos+1]!=str[i])
        {
            pos=next_num[pos];
        }
        if (str[pos+1]==str[i])
        {
            pos++;
        }
        next_num[i]=pos;
    }
}
void ans(int n)
{
    if (next_num[n]!=0)
    {
        ans(next_num[n]);
    }
    printf("%d ",n);
    return ;
}
int main()
{
    while (scanf("%s%*c",str+1)!=EOF)
    {
        int n=strlen(str+1);
        getnext(n);
        ans(n);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值