POJ2752 Seek the Name, Seek the Fame

2 篇文章 0 订阅

Seek the Name, Seek the Fame

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27506 Accepted: 14240
Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input

ababcababababcabab
aaaaa
Sample Output

2 4 9 18
1 2 3 4 5

问题连接

问题描述

给了一个字符串s,找到s的前缀后缀相同的子串,以升序输出它们的长度。

问题分析

kmp算法中next数组的应用。next[i]表示以第i个字符结尾的子串与原字符串前缀匹配的长度(写的时候next[i]的值比匹配的前缀长度相差1),或者说是已经匹配的前缀的最后一个字符的下标。因为前缀和后缀是相同的,所以原本要在原串末尾找下一个满足条件的子串,可以通过next数组跑到前缀子串的结尾字符位置找题意要的子串。得到next数组后,从后往前推,把放入栈里,实现倒序输出。
以下代码中F数组是next数组。

代码如下

#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;

const int N = 4e5 + 5;

char str[N];
int F[N], n;

void getF() {
	n = strlen(str);
	F[0] = -1;
	for (int i = 1; i < n; i++) {
		int j = F[i - 1];
		while (str[j + 1] != str[i] && j >= 0) j = F[j];
		if (str[j + 1] == str[i]) F[i] = j + 1;
		else F[i] = -1;
	}
}

int main() {
	while (~scanf("%s",str)) {
		getF();//得到next数组
		stack<int> S;
		int i = n - 1;
		while (F[i] != -1) {
			S.push(i + 1);
			i = F[i];
		}
		S.push(i + 1);
		printf("%d",S.top());
		S.pop();
		while (!S.empty()) {
			printf(" %d",S.top());
			S.pop();
		}
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值