week12-动态规划(三)A-必做题-1

A - 必做题 - 1

给出n个数,zjm想找出出现至少(n+1)/2次的数, 现在需要你帮忙找出这个数是多少?

Input

本题包含多组数据:每组数据包含两行。
第一行一个数字N(1<=N<=999999) ,保证N为奇数。
第二行为N个用空格隔开的整数。
数据以EOF结束。

Output

对于每一组数据,你需要输出你找到的唯一的数。

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output
3
5
1

解题思路

本题要找到出现了(n+1)/2次及以上的数,那么这个数一定是唯一的,所以可以先升序排序。
然后计算相同的数的个数,如果那个数的个数超过了(n+1)/2,那么遍历结束,输出那个数。

Codes

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1e6 + 10;
int n,a[maxn],num;
int main(){
    while (scanf("%d",&n) != EOF){
        int tag = 0;
        memset(a, 0, sizeof(a));
        for (int i = 1; i <= n;i++)
            cin >> a[i];
        num = (n + 1) / 2;
        sort(a+1, a + n+1, less<int>());
        for (int i = 1; i <= n;i++){
            if(a[i]!=a[i+1]){
                tag = i-tag;
                if(tag>=num){
                    cout << a[i] << endl;
                    break;
                }
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值