Number Sequence

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2…Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
Output

There should be one output line per test case containing the digit located in the position i.
Sample Input

2
8
3
Sample Output

2
2

#include<bits/stdc++.h>
using namespace std;
int a[31270];
long long b[31270];
void init(){
    int i;
    a[0] = 0;
    b[0] = 0;
    for(i = 1; i < 31270; i++){
        a[i] = a[i-1] + (int)log10((double)i) + 1;
        b[i] = b[i-1] + a[i];
    }
}
int main(){
    init();
    int K,n,i;
    cin>>K;
    while(K--){
        cin>>n;
        i = 0;
        while(n > b[i])
            i++;
        int pos = n - b[i-1];
        int s = 0;
        for(i = 1; s < pos; i++)
        s += (int)log10((double)i) + 1;
        int k=s-pos;
        printf("%d\n",(i-1)/(int)pow(10.0,k)%10);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值