POJ 2104 K-th Number

POJ 2104 K-th Number

题目链接

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

主席树模板题,查询区间第 k k k 大的值,AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=2e5+5;

int n,m,siz,l,r,k,cnt=0;
int a[N];//原数组
int s[N];//去重后的数组
int rk[N];//记录原数组的元素的排名
int root[N];//记录每个根节点的编号

struct ptree{
    int l,r,sum;//sum记录经过该节点的次数
}t[N*20];

void build(int &node,int l,int r){
    node=++cnt;
    if(l==r) return;
    int mid=l+r>>1;
    build(t[node].l,l,mid);
    build(t[node].r,mid+1,r);
}

void update(int &node,int last,int l,int r,int s){
    node=++cnt;
    t[node]=t[last];
    ++t[node].sum;
    if(l==r) return;
    int mid=l+r>>1;
    if(s<=mid) update(t[node].l,t[last].l,l,mid,s);
    else update(t[node].r,t[last].r,mid+1,r,s);
}

int query(int node,int last,int l,int r,int k) {
    if (l == r) return s[l];
    int sum = t[t[node].l].sum - t[t[last].l].sum, mid = l + r >> 1;
    if (k <= sum) return query(t[node].l, t[last].l, l, mid, k);
    else return query(t[node].r, t[last].r, mid + 1, r, k - sum);
}

int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++) scanf("%d",&a[i]);
    memcpy(s,a,sizeof(s));
    sort(s+1,s+1+n);
    siz=unique(s+1,s+1+n)-s-1;
    build(root[0],1,siz);
    for(int i=1;i<=n;i++) rk[i]=lower_bound(s+1,s+1+siz,a[i])-s;
    for(int i=1;i<=n;i++) update(root[i],root[i-1],1,siz,rk[i]);
    while(m--){
        scanf("%d%d%d",&l,&r,&k);
        printf("%d\n",query(root[r],root[l-1],1,siz,k));
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺 崽

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值