POJ3250牛的视野

Bad Hair Day

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25761 Accepted: 8794

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

Source

USACO 2006 November Silver

 题目要求每头牛能看到的牛的数目之和,即是求每头牛可以被其他牛看到的数目之和。可以声明一个栈,每加入一个牛时,就把栈中的比该元素小的牛删除,这样栈中的牛都能看到这头牛,栈中元素的个数就是能看到这头牛的个数。每次都把这头牛加入栈中,维护单调栈,可以得知栈中元素总是单调递减的。 
1

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<string.h>
#include<iterator>
#include<vector>
#include<stdlib.h>
#include<map>
#include<queue>
#include<stack>
#include<set>
#include<sstream>
typedef long long ll;
using namespace std;

int main()
{
    int n,h,t;
    ll sum=0;
    scanf("%d",&n);
    stack<int> s;
    scanf("%d",&h);
    s.push(h);
    for(int i=1;i<n;i++){
        scanf("%d",&t);
        while(!s.empty()&&t>=s.top()){//注意这里,两个条件不能够把顺序写反,否则会Runtime Error
            s.pop();
        }
        sum+=s.size();
        s.push(t);
    }
    printf("%lld\n",sum);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值