hdu1829 A Bug's Life(并查集)

 

(点击进入报名链接)~

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22002    Accepted Submission(s): 6992


 

Problem Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

 

 

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

 

 

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

 

 

Sample Input

 

2 3 3 1 2 2 3 1 3 4 2 1 2 3 4

 

 

Sample Output

 

Scenario #1: Suspicious bugs found!

Scenario #2: No suspicious bugs found!

Hint

Huge input,scanf is recommended.

 

 

Source

TUD Programming Contest 2005, Darmstadt, Germany

 

 

Recommend

linle

这道题的关键是找到两个集合合并的关系,类似于食物链那道题,找关系用向量法去找

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 2005;
int fa[maxn],re[maxn];  //父节点数组,关系数组
bool flag;  //用来表示是否有bug存在

int Find(int x)  //状态压缩
{
    if(fa[x] == x) return fa[x];
    int temp = Find(fa[x]);
    re[x] = (re[x] + re[fa[x]])&1;
    fa[x] = temp;
    return fa[x];
}

void Union(int x,int y)
{
    int xx = Find(x);
    int yy = Find(y);
    if(xx == yy){     //属于同一个根
        if(re[x] == re[y])  //2个bug原来的关系是互斥的,但是现在给出的关系是不互斥,很明显矛盾
            flag = true;
        return ;
    }
    fa[xx] = yy;
    re[xx] = (re[x] - re[y] + 1)&1;  //其实原来别人写的是 (re[x] +re[y] + 1)&1,但是我们推导的是这个,两个都能过
}

int main()
{
    int T;
    scanf("%d", &T);
    for(int kase = 1; kase <= T; kase++)
    {
        int n,m,x,y;
        scanf("%d%d", &n, &m);
        for(int i = 1; i <= n; i++)
        {
            fa[i] = i;
            re[i] = 0;
        }
        flag = false;
        for(int i = 1; i <= m; i++)
        {
            scanf("%d%d", &x, &y);
            if(flag) continue;   //已经有bug存在,接下来的就不用判断了
            Union(x,y);
        }
        printf("Scenario #%d:\n", kase);
        if(flag) printf("Suspicious bugs found!\n\n");
        else printf("No suspicious bugs found!\n\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值