Sum of Consecutive Prime Numbers POJ - 2739 (做了一下午,来看看孩子的成果吧,哭了)

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2
#include<stdio.h>
#include<string.h>
#define MAXN 100000
#define MAXL 100000
bool check[MAXN];///判断素数
int prime[MAXL];///保存素数
int n;
int main()///打表
{
    ///埃拉托斯特尼筛法
    int count = 0;///一开始初始化为0;
    memset(check, 0, sizeof(check));
    for (int i = 2; i <= 100000; i++)
    {///就是这里啊啊啊啊啊啊啊!!!!只要前一万个素数,但是后边的也得给空间,筛的时候大于10000啊啊啊啊啊啊啊啊啊啊啊啊!!!!
        ///从2开始
        if (!check[i])///如果是0的话,就是素数
            prime[count++] = i;///count记录个数
        for (int j = i + i; j <= 10000; j += i)///只要前一万!!!!
            check[j] = 1;///素数的倍数全部筛掉
    }
    while(~scanf("%d",&n)&&n)
    {
        int s,e,sum,ans;///ans为个数
        e=s=sum=ans=0;///全部归0
        while(1)
        {
            if(sum==n)
                ans++;///素数和为n,找到+1
            if(sum>=n)
                sum-=prime[s++];///到右端点和超过了,左端点开始移动
            else
            {
                ///和还不够
                if(prime[e]<=n)
                    sum+=prime[e++];///右端点的素数比要找的数小,右端点移动
                else
                    break;///右端点的素数已经大于要找的数了,退了退了
            }
        }
        printf("%d\n",ans);
    }
}
inline char gc()
{
    static char buff[100000000],*S=buff,*T=buff;
    return S==T&&(T=(S=buff)+fread(buff,1,100000000,stdin),S==T)?EOF:*S++;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值