POJ 2739 Sum of Consecutive Prime Numbers

POJ 2739 Sum of Consecutive Prime Numbers

Sum of Consecutive Prime Numbers

Time Limit: 1000MS

Memory Limit: 65536K

Total Submissions: 26176

Accepted: 14204

Description

Some positiveintegers can be represented by a sum of one or more consecutive prime numbers.How many such representations does a given positive integer have? For example,the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 hasonly one representation, which is 3. The integer 20 has no suchrepresentations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for theinteger 20. 
Your mission is to write a program that reports the number of representationsfor the given positive integer.

Input

The input is asequence of positive integers each in a separate line. The integers are between2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output shouldbe composed of lines each corresponding to an input line except the last zero.An output line includes the number of representations for the input integer asthe sum of one or more consecutive prime numbers. No other characters should beinserted in the output.

Sample Input

2

3

17

41

20

666

12

53

0

Sample Output

1

1

2

3

0

0

1

2

 

 

先生成素数表,根据素数表求连续素数的和,最后根据输入查询即可

 

 

代码:

//POJ 2739 Sum of COnsecutive Prime Numbers

#define LOCAL

#include <iostream>

#include <cstring>

#include <vector>

using namespace std;

const int MAX = 10050;

bool isprime[MAX];

int prime[MAX];

int top;

int counter[MAX];

void initPrimeArray(){

    top = 1;

    memset(isprime,true,sizeof prime);

    for(int i=2;i<MAX;i++)

        if(isprime[i]){

            prime[top++]= i;

            for(int j=i*2;j<MAX;j+=i)

                isprime[j]= false;

        }

}

 

void initCounter(){

    std::vector<int> sum(top,0);

    memset(counter,0,sizeof counter);

    for(int i=1;i<top;i++){

        sum[i]= sum[i-1]+ prime[i];

        for(int j=0;j<i;j++)

            if(sum[i]-sum[j]<MAX)

                counter[sum[i]-sum[j]]++;

    }

}

 

int main(int argc,char const *argv[])

{

    initPrimeArray();

    initCounter();

    #ifdef LOCAL

    freopen("in.txt","r",stdin);

    #endif

    int n;

    while(cin>>n&&n){

        cout<<counter[n]<<endl;

    }

    return 0;

}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值