POJ-2184 Cow Exhibition(0/1背包和负数的处理)

题目链接看这里鸭
Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17334 Accepted: 7078
Description

“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”

  • Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input

  • Line 1: A single integer N, the number of cows

  • Lines 2…N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output

  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output

8
Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.
Source

USACO 2003 Fall

题意:找到一群牛中的智力si和搞笑力fi和最大的数为多少,其中智力和搞笑力都不能为负数。
思路:使用0/1背包的想法,把智力看成费用,把搞笑力看作价值,则有DP[C]=D表示在智力为C的时候最大的搞笑力为D.由于这道题中有负数的存在,我们可以把负数域移到正数域去。但是这里就有值得注意的地方:使用了0/1背包的二维DP降成一维DP时出现了负数需要从小到大进行遍历,大家自己模拟一下吧。

下面就是代码啦

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <stack>
using namespace std;
const int maxn = 2e5+100;
const int inf = 0x3f3f3f3f;
const int mod = 10000;
typedef long long ll;
int n;
int s[105],f[105];
int dp[maxn];
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d %d",&s[i],&f[i]);
    }
    memset(dp,-inf,sizeof(dp));
    dp[100000]=0;
    for(int i=1;i<=n;i++){
        if(s[i]<0&&f[i]<0)continue;
        if(s[i]>0){
            for(int j=200000;j>=s[i];j--){
                if(dp[j-s[i]]>-inf)
                dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
            }
        }
        else{
            for(int j=0;j<=200000+s[i];j++){
                if(dp[j-s[i]]>-inf)
                dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
            }
        }
    }
    int ans=-inf;
    for(int i=100000;i<=200000;i++){
        if(dp[i]>=0){
            ans=max(ans,dp[i]+i);
        }
    }
    cout<<ans-100000<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值