Godfather(树状DP和树的重心)

题目如下:
Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input
The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output
Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input
6
1 2
2 3
2 5
3 4
3 6
Sample Output
2 3

题意:找到给定的树的所有重心,

题目思路:首先关于树的重心,我的理解就是树去掉某个节点后树分成了若干个子树,其中使得他分出的子树中节点最多的子树是删除其他节点所剩下的子树的最大子树中的最下子树。
同时本题已知所给的数据是树形结构的,故用DFS对树进行遍历可以不用担心出现环的情况。
而树形DP我认为就是把原本DP的线性结构变成了现在的树性结构,不同线性结构的直接遍历,树形结构要借助DFS来进行遍历。具体的内容见下面的代码吧

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <cmath>
using namespace std;
const int maxn = 50010;
const int maxn2= 100010;
const int inf =0x3f3f3f3f;
const int mod = 10007;
int n,m,cnt=0,minn=inf,res=0;
int head[maxn],son[maxn];
int ans[maxn];
struct node{
    int y,p;
}s[maxn<<1];
void add(int a,int b){
    s[++cnt]=node{b,head[a]};
    head[a]=cnt;
}
void dfs(int u,int fa){
    int maxf=-100;
    for(int i=head[u];~i;i=s[i].p){
        int v=s[i].y; if(v==fa) continue;
        dfs(v,u);son[u]+=son[v]+1;
        maxf=max(maxf,son[v]+1);
    }
    maxf=max(maxf,n-son[u]-1);
    if(maxf==minn){
        ans[res++]=u;
    }else if(maxf<minn){
        res=0;
        minn=maxf;
        ans[res++]=u;
    }
}
int main()
{
    while(~scanf("%d",&n)){
        memset(head,-1,sizeof(head));memset(son,0,sizeof(son));minn=inf;
        cnt=0;memset(ans,0,sizeof(ans));res=0;
        for(int i=1;i<n;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            add(a,b);add(b,a);
        }
        dfs(1,-1);
        sort(ans,ans+res);
        for(int i=0;i<res;i++){
            if(i!=res-1) printf("%d ",ans[i]);
            else printf("%d\n",ans[i]);
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值