hdu-1542,Atlantis(扫描线模板)

Atlantis
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24907 Accepted Submission(s): 9836

Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

Sample Input
2
10 10 20 20
15 15 25 25.5
0

Sample Output
Test case #1
Total explored area: 180.00

Source
Mid-Central European Regional Contest 2000

Recommend
linle

题目思路:扫描线的模板,用来解决与坐标轴平行的有重叠的四边形的面积之和的问题,目的是复杂度从o(n^2)降低到O(nlogn),方法通过枚举一维,在通过线段树查找一维。线段树是维护离散化后的数组区间长度,注意对于区间有[l,l]是指第L个区间,而[l.r]指的是第L个到第R个区间的长度。

代码如下:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <cmath>
#include <map>
#include <vector>
using namespace std;
typedef long long ll;
const int maxn = 220;
const int maxn2= 6010;
const int inf =0x3f3f3f3f;
int n,m;
double lsan[maxn];
struct node{
    double x1,x2,y1;
    int val;
}p[maxn<<2];
struct node2{
    double sum;
    int res;
}s[maxn<<2];
int cmp(node a,node b){
    return a.y1<b.y1;
}
void push_down(int root,int l,int r){
    if(s[root].res) s[root].sum=(lsan[r+1]-lsan[l]);
    else if(l==r) s[root].sum=0.;
    else s[root].sum=s[root<<1].sum+s[root<<1|1].sum;
}
void update(int root,int l,int r,int nl,int nr,int val){
    if(l==nl&&nr==r){
        s[root].res+=val;
        push_down(root,l,r);
        return;
    }
    int mid=(l+r)>>1;
    if(nr<=mid) update(root<<1,l,mid,nl,nr,val);
    else if(nl>mid) update(root<<1|1,mid+1,r,nl,nr,val);
    else{
        update(root<<1,l,mid,nl,mid,val);
        update(root<<1|1,mid+1,r,mid+1,nr,val);
    }
    push_down(root,l,r);
}
int main()
{
    int cas=0;
    while(~scanf("%d",&n)){
        if(n==0) break;
        int cnt=1;cas++;
        for(int i=1;i<=n;i++){
            double x1,y1,x2,y2;
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            p[cnt]=node{x1,x2,y1,1}; lsan[cnt++]=x1;
            p[cnt]=node{x1,x2,y2,-1}; lsan[cnt++]=x2;
        }
        sort(p+1,p+cnt,cmp);sort(lsan+1,lsan+cnt);
        int len=unique(lsan+1,lsan+cnt)-lsan;
        double ans=0;
        for(int i=1;i<cnt;i++){
            int l=lower_bound(lsan+1,lsan+len,p[i].x1)-lsan;
            int r=lower_bound(lsan+1,lsan+len,p[i].x2)-lsan-1;
            update(1,1,len,l,r,p[i].val);
            ans+=s[1].sum*(p[i+1].y1-p[i].y1);
        }
        printf("Test case #%d\nTotal explored area: %.2lf\n\n",cas,ans);
    }
    return 0;
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值