HDU - 1542 Atlantis(线段树+扫描线+离散化)

HDU - 1542 Atlantis

Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 
题目大意:二维平面有n个平行于坐标轴的矩形,现在要求出这些矩形的总面积. 重叠部分只能算一次.
样例解释

样例所示地图覆盖区域如下图所示,两个矩形区域所覆盖的总面积,即为样例的解。

在这里插入图片描述

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int N = 100010;

struct Segment
{
	double x,y1,y2;
	int k;
	bool operator <(const Segment &c) const{
		return x<c.x;
	}
}seg[N<<1];

struct Node
{
	int l,r,cnt;
	double len;
}tr[N<<3];

vector<double> ys;

int find(double y)
{
	return lower_bound(ys.begin(),ys.end(),y)-ys.begin();
}
void pushup(int u)
{
	if(tr[u].cnt)
		tr[u].len=ys[tr[u].r+1]-ys[tr[u].l];
	else if(tr[u].l!=tr[u].r)
		tr[u].len=tr[u<<1].len+tr[u<<1|1].len;
	else
		tr[u].len=0;
}
void build(int u,int l,int r)
{
	tr[u]={l,r,0,0};
	if(l!=r)
	{
		int mid=(l+r)>>1;
		build(u<<1,l,mid);
		build(u<<1|1,mid+1,r);
	}
}
void modify(int u,int l,int r,int k)
{
	if(tr[u].l>=l&&tr[u].r<=r)
	{
		tr[u].cnt+=k;
		pushup(u);
	}
	else
	{
		int mid=(tr[u].l+tr[u].r)>>1;
		if(l<=mid) modify(u<<1,l,r,k);
		if(r>mid) modify(u<<1|1,l,r,k);
		pushup(u);
	}
}
int main()
{
	int T=1,n;
	while(scanf("%d",&n),n)
	{
		ys.clear();
		for(int i=0,j=0;i<n;i++)
		{
			double a,b,c,d;
			scanf("%lf%lf%lf%lf",&a,&b,&c,&d);
			seg[j++]={a,b,d,1};
			seg[j++]={c,b,d,-1};
			ys.push_back(b);ys.push_back(d);
		}
	
		sort(ys.begin(),ys.end());
		ys.erase(unique(ys.begin(),ys.end()),ys.end());
		
		build(1,0,ys.size()-2);
		sort(seg,seg+n*2);
		
		double res=0;
		for(int i=0;i<n*2;i++)
		{
			if(i>0) res+=tr[1].len*(seg[i].x-seg[i-1].x);
			modify(1,find(seg[i].y1),find(seg[i].y2)-1,seg[i].k);
		}
		printf("Test case #%d\n",T++);
		printf("Total explored area: %.2lf\n",res);
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wa_Automata

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值