Slim Span--POJ 3522&UVA 1395--最小生成树+枚举

Slim Span

Time Limit: 5000MS Memory Limit: 65536K

题目链接http://poj.org/problem?id=3522

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.
在这里插入图片描述
Figure 5: A graph G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

在这里插入图片描述
There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), © and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n m
a1 b1 w1

am bm wm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50


emmmm,题目大意:给你n个点和m条边,让你求一颗生成树使得生成树的最大边权和最小边权的差值最小,如果无法构成一颗树,输出-1。

这题算是比较简单的一题吧,根据最小生成树的克鲁斯卡尔算法我们是先将边权按照最小值来排序,最后一个个取过去,然后套一个并查集判断就好了。

那么我们为什么要按照边权的最小值排序呢?答案很显然,我们求的是最小生成树,需要的就是所有的边权最小,这也算的上是一种贪心算法吧。一个个边取去过,知道一张图连通了就ok了。

那么这题也是一样的,按照最小值排序,然后我们就会发现相邻的两项之差会是最小的。我们可以枚举最小的边权然后跑最小生成树就好了。

以下是AC代码:

//#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int mac = 1e5 + 10;
const int inf = 1e9 + 10;
struct node
{
	int u, v, w;
	bool operator <(const node& a)const {
		return a.w > w;
	}
};
node edge[mac];
int father[mac];
int find(int x)
{
	return x == father[x] ? x : father[x] = find(father[x]);
}
int main()
{
	//freopen("in.txt", "r", stdin);
	int n, m;
	while (scanf("%d%d", &n, &m)) {
		if (!n && !m) break;
		memset(father, 0, sizeof(father));
		memset(edge, 0, sizeof(edge));
		int u, v, w;
		for (int i = 0; i < m; i++) {
			scanf("%d%d%d", &u, &v, &w);
			edge[i].u = u, edge[i].v = v;
			edge[i].w = w;
		}
		sort(edge , edge + m);
		int ans = inf;
		for (int i = 0; i < m; i++) {
			for (int j = 0; j <= n; j++) father[j] = j;
			int cnt = 0;
			for (int j = i; j < m; j++) {
				int fa = find(edge[j].u), fb = find(edge[j].v);
				if (fa != fb) {
					father[fa] = fb;
					cnt++;
					if (cnt == n - 1) {
						ans = min(ans, edge[j].w - edge[i].w);
					}
				}
			}
		}
		if (ans == inf) printf("-1\n");
		else printf("%d\n", ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值