竖式问题
找出所有形如abc*de(三位数乘以两位数)的算式,使得在完整的竖式中,所有数字都属于一个特定的数字集合。输入数字集合(相邻数字之间没有空格),输出所有竖式。每个竖式前应有编号,之后应有一个空行。最后输出解的总数。具体格式见样例输出(为了便于观察,竖式中的空格改用小数点显示,但你的程序应该输出空格,而非小数点)。
样例输入:2357
样例输出:
<1>
..775
X..33
-----
.2325
2325.
-----
25575
The number of solutions = 1
分析
题目大意是:找出所有三位数abc*de(两位数),在乘法算式中
的所有的数字都必须属于给定的集合,乘法算式中间结果包括abc
*(de/10)和abc*(de%10),最终结果是abc*de,我们只需枚举
所有三位数和两位数,检测所有的数字是否属于给定集合就可以了
代码
#include<bits/stdc++.h>
using namespace std;
int main() {
string s;
char buff[20];
int count = 0;
cin >> s;
for (int abc = 100; abc < 1000; abc++) {
for (int de = 10; de < 100; de++) {
int x = abc * (de % 10), y = abc * (de / 10), z = abc * de;
sprintf(buff, "%d%d%d%d%d", abc, de, x, y, z);
int ok = 1;
for (int i = 0; i < strlen(buff); i++) {
if (s.find(buff[i]) == s.npos)
ok = 0;
}
if (ok == 1) {
printf("<%d>\n", ++count);
printf("%5d\nX%4d\n-----\n%5d\n%-5d\n-----\n%5d\n", abc, de, x, y, z);
}
}
}
printf("The number of solutions = %d", count);
return 0;
}