又是打表找规律

A Central Meridian (ACM) Number N is a positive integer satisfies that given two positive integers A and B, and among A, B and N, we have 
N | ((A^2)*B+1) Then N | (A^2+B) 
Now, here is a number x, you need to tell me if it is ACM number or not. 

Input

The first line there is a number T (0<T<5000), denoting the test case number. 
The following T lines for each line there is a positive number N (0<N<5000) you need to judge.

Output

For each case, output “YES” if the given number is Kitty Number, “NO” if it is not.

Sample Input

2
3
7

Sample Output

YES
NO


        
  

Hint

Hint
X | Y means X is a factor of Y, for example 3 | 9;
X^2 means X multiplies itself, for example 3^2 = 9;
X*Y means X multiplies Y, for example 3*3 = 9.

【思路】

打表:

#include <iostream>
#include <cstring>
using namespace std;
int f[5001];
void init()
//打表找规律的函数
{
    for(int i=1; i<=5000; i++)
    {
        for(int j=1; j<=1000; j++)
        {
            for(int k=1; k<=1000; k++)
            {
                if((j*j*k+1)%i==0&&(j*j+k)%i!=0)
                {
                    f[i]=1;
                    break;
                }
            }
            if(f[i]==1)
                break;
        }
    }
    for(int i=1;i<=5000;i++)
        if(f[i]==0)
        cout<<i<<endl;
}
int main()
{
    init();
}

正式代码:

#include<iostream>
using namespace std;
int t;
int n;
int f[5001];
void init()
{
    f[1]=1;
    f[2]=1;
    f[3]=1;
    f[4]=1;
    f[5]=1;
    f[6]=1;
    f[8]=1;
    f[10]=1;
    f[12]=1;
    f[15]=1;
    f[16]=1;
    f[20]=1;
    f[24]=1;
    f[30]=1;
    f[40]=1;
    f[48]=1;
    f[60]=1;
    f[80]=1;
    f[120]=1;
    f[240]=1;
}
int main()
{
    init();
    ios::sync_with_stdio(false);
    cin>>t;
    while(t--)
    {
        cin>>n;
        if(f[n]==1)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值