HDU-4585(Shaolin)

Problem Description

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.

When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.

The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.

Input

There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk’s id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.

Output

A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk’s id first ,then the old monk’s id.

Sample Input

3
2 1
3 3
4 2
0

Sample Output

2 1
3 2
4 2

题目大意

再寺庙里有一个大和尚(第一个和尚ID为1战斗力为1000000000)以后每一个加入的和尚都需要进行一场比试
规则是跟最接近自己战斗力的比,当两个和尚与其战斗力差一样时与ID小的比试,大和尚丢失了历来的战斗情况
但是知道和尚们加入的先后和战斗力,按顺序给出加入的和尚的ID和战斗力(在前面的先加入).需要你打印出战斗情况
比如样例2 1表示加入了一个ID为2,战斗力为1的和尚,此时寺里只有大和尚,就跟大和尚比,大和尚ID为1就打印2 1,3 3表示加入了一个ID为3,战斗力为3的和尚,他和ID为2战斗力为1的和尚战斗力差最小所以和他比,所以输出3 2,最后输入4 2表示加入一个ID为4,战斗力为2的和尚,他和ID为2战斗力为1和尚以及ID为3战斗力为3的和尚战斗力都相差1,所以选择ID小的2,所以输出4 2

解题思路

用map将ID和战斗力联系起来,可以用lower_bound()找到大于等于新加入的和尚的战斗力…
还是直接看代码吧!!

AC代码

#include <cstdio>
#include<map>
using namespace std;
int main()
{
    map<int,int>m;//建立ID和战斗力的关系
    int n;
    while(~scanf("%d",&n)&&n)
    {
        m.clear();
        m[1000000000]=1;//由于这个比试是按照战斗力进行选择的所以把战斗力作为键值
        int x,y;
        while(n--)
        {
            scanf("%d %d",&x,&y);
            printf("%d ",x);
            map<int,int>::iterator it;//定义迭代器,指向map里的元素,可以在map中移动
            it=m.lower_bound(y);//让it指向战斗力大于等于新加入的和尚的第一个元素
            if(it==m.begin())//当it指向开始也就意味着战斗力比他大的和尚是寺庙里战斗力最小的,直接和他比
                printf("%d\n",it->second);
            else//否则也就意味着有战斗力比他大的和尚也有战斗力比他小的和尚,需要判断
            {
                int x1,y1;
                y1=it->first;
                x1=it->second;
                it--;
                if(y1-y<y-it->first)
                    printf("%d\n",x1);
                else
                    printf("%d\n",it->second);
            }
            m[y]=x;
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值