Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe
asd
zxc
Sample Output
e q w
a d s
c x z
#include <iostream>
using namespace std;
int main()
{
char a[3] = { 0 };
while (cin >> a)
{
char b;
for (int pass = 0; pass < 2; pass++)
for (int i = 0; i < 2; i++)
if (a[i] > a[i + 1])
{
b = a[i];
a[i] = a[i + 1];
a[i + 1] = b;
}
cout << a[0] << " " << a[1] << " " << a[2] << endl;
}
}