Virgo's Trial第D题

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Input
abcfbc abfcab
programming contest
abcd mnp
Output
4
2
0
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0

问题链接:https://vjudge.net/contest/279627#problem/D
问题简述:首先明白题目要求的最长子序列,
子序列不是子串,子序列是这些字符不是连续的 但是有先后顺序;子串是连续的。
abc(f)b( c)和ab(f)c(a)b 如abcb是其一个最长子序列。
问题分析:这是一个动态储存,用一个二维数组储存;
首先建立一个表格;
当比较相等时就是左上角的情况加1,不同就是列表上边或者左边的一个最大的值。

#include <iostream>
#include<cstring>
int max(int a, int b)
{
	if (a > b)return a;
	else return b;
}
using namespace std;
int main()
{
	char A[2000];
	char B[2000];
	int C[2100][2100];
	int a, b, i, j;
	while (cin >> A && cin >> B)
	{
		memset(C, 0, sizeof(C));
		a = strlen(A);
		b = strlen(B);
		for (i = 1; i < a+1; i++)
		{
			for (j = 1; j < b+1; j++)
			{
				if (A[i-1] == B[j-1])
					C[i][j] = C[i-1][j-1] + 1;
				else C[i][j] = max(C[i - 1][j], C[i][j - 1]);
			}
		}
		cout << C[a][b] << endl;
		memset(A, '\0', sizeof(A));
		memset(B, '\0', sizeof(B));
	}
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值