PAT (Advanced Level) 1019 General Palindromic Number (20分)JAVA实现

在这里插入图片描述

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1


import java.util.Scanner;
 
public class Main{

    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int n, b, index=1;
        n = scanner.nextInt();
        b = scanner.nextInt();
        int[] num = new int[40];
        do{
            num[index++] = n%b;
            n = n/b;
        }while (n!=0);
        boolean tag = true;
        for(int i=1; i<index-i; ++i) {
            if (num[i]!=num[index-i]) {
                tag = false;
                System.out.println("No");
                break;
            }
        }
        if (tag) {
            System.out.println("Yes");
        }
        --index;
        System.out.print(num[index]);
        while(index>1) {
            --index;
            System.out.print(" "+num[index]);
        }
 
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值