PAT (Advanced Level) 1027 Colors in Mars (20分)JAVA实现

在这里插入图片描述

Sample Input:

15 43 71

Sample Output:

#123456



import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		//System.out.println(Integer.toString(15, 13));
		int a = sc.nextInt();
		int b = sc.nextInt();
		int c = sc.nextInt();
		String string = Integer.toString(a, 13).toUpperCase();
		String string2 = Integer.toString(b, 13).toUpperCase();
		String string3 = Integer.toString(c, 13).toUpperCase();
		StringBuffer sb1 = new StringBuffer(string);
		StringBuffer sb2 = new StringBuffer(string2);
		StringBuffer sb3 = new StringBuffer(string3);
		
		if(string.length()==1) {
			sb1.insert(0, "0");
			
		}
		System.out.print("#"+sb1);
		if(string2.length()==1) {
			sb2.insert(0, "0");
			
		}
		System.out.print(""+sb2);
		if(string3.length()==1) {
			
			sb3.insert(0, "0");
			
		}
		System.out.print(""+sb3);
	}

	
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值